locked
Remoting first method call RRS feed

  • Question

  • The time delay on the first method call is significant.
    I am using the TcpChannel with the BinaryClientFormatterSinkProvider.
    Using the Server Activated Object the initialisation occurs when the first method call takes place.

    Having written a simple application to test the problem when I make the first method call on a local machine it takes around 1 second which is acceptable. Over my network (100mbps) the same first method takes around 20 seconds.
    I have also tested using the HttpChannel and as expected the delay increases for the first call, locally 9 seconds and on a remote machine 29 seconds.

    Once the initial call is made the remoting calls are fast, less than a millisecond.

    Could the issue relate to a network setting, firewall/security setting? I have been developing on Vista.

    The commercial application I am developing needs to connect to 20+ stations on a local network. My thoughts are if this issue is part of the technology then I would use a thread pool for the initiial calls to each station as a work around.
    Thursday, June 4, 2009 8:06 AM

Answers

  • It may be of interest the problem was resolved by turning off the Windows Firewall.

    There is possibly a firewall setting to overcome the issue.

    James
    • Marked as answer by James-c Tuesday, November 17, 2009 3:28 PM
    Tuesday, November 17, 2009 3:27 PM

All replies

  • I think this is related to your HTTP proxy settings on the client side. This thread might be of help: http://social.msdn.microsoft.com/Forums/en-US/netfxremoting/thread/dc2d1638-5556-4bff-8c05-a0bf1c8afc39/

    -steve


    Brain.Save() -- http://hyperthink.net/blog
    Friday, June 5, 2009 11:43 PM
    Moderator
  • Thanks for the information.

    I did take a look at this before but I am using the TcpChannel and I thought that the HttpWebRequest is just for using HTTP connections.

    What I will try and do is run some tests on a different network to see if there are any speed differences.

    James
    Tuesday, June 9, 2009 10:12 AM
  • It may be of interest the problem was resolved by turning off the Windows Firewall.

    There is possibly a firewall setting to overcome the issue.

    James
    • Marked as answer by James-c Tuesday, November 17, 2009 3:28 PM
    Tuesday, November 17, 2009 3:27 PM