locked
Mobile Device Center - My HTC HD2 is not recognized

    Question

  • Hi every one,

    First of all, thanks Microsoft for this new trends and ideas of OS.

    Since I installed the Metro, I am unable to connect any mobile device to my desktop machine.

    Windows Device Center is not start automatically once I connected my device to PC. Even I opened it manually, it is not connect to my device.

    I am Using Windows Mobile 6.5 over HTC HD2.


    Pr.wa'el .Net Professional
    Monday, September 19, 2011 1:05 AM

All replies

  • Hey Wa'el,

    Is the only device you've tried connecting to your PC the Windows Mobile Phone?  Have you tried connecting other devices to your PC and what was the result?

    Regards,

    Gary

    Monday, September 19, 2011 9:54 PM
    Answerer
  • I'm using an htc ozone with windows 6.5 mobile and mine won't connect either. It tries to run mobile device center to connect to the phone. The program starts, it brings up a window asking to make changes to .net framework 3.5.1, when i accept this it proceeds to try to download an update, then it hangs for 5 min or so, then it gives me an error and starts this whole process over. it loops and brings up multiple windows to begin all this the longer the phone is plugged in.
    Tuesday, September 20, 2011 9:42 PM
  • Hello,

    I think that you both should try a Refresh to see if that helps with the problem of connecting your HTC devices.  A Refresh will restore your default PC settings and will retain your files and personalizations, although you will have to reinstall any desktop applications that you have installed. 

    To perform the Refresh, go to the Metro UI Control Panel, choose General, then click the Get Started button next to Refresh your PC and follow the prompts. 

    Once the Refresh is complete, attempt to connect the device and again and reply with the results.

     

    Thanks,

    Gary

    Wednesday, September 21, 2011 2:21 PM
    Answerer
  • It is looking to see if you have .Net Framework 3.5.1 enabled.
    Go to Control Panel, Click on More Settings.
    Next, click on Programs and Features. On the left pane, click "Turn Windows Features on or Off".
    Scroll to see if there is a check mark in the box next to .Net Framework 3.5.1. It is in the Operating System but not enabled by default.

    Be sure it is enabled, then try to connect your device again.

    Thanks,
    Marilyn
    Wednesday, September 28, 2011 1:46 AM
    Moderator