none
clr20r3 mscorlib error RRS feed

  • Question

  • Hello All,

    My .NET 2 application gets closed abnormally without any exception. The only thing visible is this error in the event log

    EventType clr20r3, P1 catalyst.cats.mainserver.exe, P2 2.5.4.0, P3 4784d05b, P4 mscorlib, P5 2.0.0.0, P6 471ebc5b, P7 3404, P8 26d, P9 system.io.ioexception, P10 NIL.


    It has been quite long since im looking to fix this error, any help will be highly appreciated.



    Regards

    M. Aamir Malik


    Friday, April 4, 2008 1:04 PM

All replies

  • What do you mean by "application gets closed abnormally without any exception" ?
    Did you put breakpoints to see what line of code generate exception ?

    Can you provide some code ?

    greet
    Friday, April 4, 2008 1:42 PM

  • Thanks for your reply

    Well, the problem is that the application sometimes gets closed abnormally.
    Actually this application (same version) is deployed at 10 different clients (all running Windows2003 Server) and only few of them are facing this problem with different frequency. One might face this problem 2-3 times in a day and the other might face once in a day or two.

    We were not able to debug the problem as it never came in testing environment.

    Please help finding any solution to this problem.

    Regards
    M.Aamir Malik
    Friday, April 4, 2008 2:05 PM
  • Look at these links:

    http://www.devnewsgroups.net/group/microsoft.public.dotnet.framework/topic42048.aspx

    http://blogs.msdn.com/elton/archive/2006/03/06/545090.aspx

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1729170&SiteID=1

    greet

    Friday, April 4, 2008 2:33 PM

  • Thanks again for your time,

    I have gone through the links you provided and tried to search similar experiences from others but no luck Sad

    The difference between there problem and my problem is that my application runs on almost every machine but it sometimes crashes. When the application gets crashed you can again double click the exe and it again started working normally. Whereas what I've found on the web and from the links you provided is that they were not being able to run it on some machines.


    Still looking for your help.

    Regards
    M. Aamir Malik
    Saturday, April 5, 2008 5:10 AM
  • Try this,

     

    I seen programs that require dot net framework 1.1 and won't work on machines that have installed

    only dot net framework 2.0, so maybe on machines that chrashes you don't have exact dot net

    framework installed, that is required for your application. Exception message looks something like

    this, it complains about some clr exception and that can be caused because of dot net framework

    version.

     

    Anyway check what .net frameworks you have on machines that don't chrash and on those that chrash,

     

    greet

    Saturday, April 5, 2008 9:34 AM
  • Basically this just means an ioexception has thrown from application catalyst.cats.mainserver.exe of version 2.5.4.0 in method 3404, IL offset 26d of assembly catalyst.cats.mainserver.exe. 

     

    I would suggest you to fire up VS and attach to the services and find out what is wrong. Using a debugger is much easier than just looking at this information.

    Monday, April 7, 2008 6:04 AM

  • As I said earlier, this error never appeared in our development or testing environments. The same code logic had been run several times in the development environment but never created the case. This is the reason why we are having difficulties in tracking this error. The application had been running in the production environment for months and one day, it just exited without any prompt or error with the above stated Error Log message.


    If we somehow manage to debug it in the real environment then we are not sure how long it will take to raise this error, because the frequency of error occurrence is not known. It might take some hours or it can span days to raise this error.
    That’s why debugging is not an option for us to track this error.

    Regards

     

    Monday, April 7, 2008 10:24 AM
  • Hi

     

    Our Application:

    3 WCF Services and are consumed by 3 Windows Workflow running under a Windows Service (Workflow Service)

    Workflow Service checks for messages in MQ periodically based on a Timer

     

    Status:

    We're in QA for the last 2 months and going to production next month

     

    Issue:

    All these were running without any issues till last Friday, until we get below error in only one of our QA Server.

     

    Environment:

    Windows 2003 Server with .NET 2.0 & 3.0 Runtime installed

     

    1. No s/w were installed recently

    2. Things were working fine till Thursday

    3. When we restart the Workflow Service, it runs without any issue, but, sometimes it's throwing this error in EventLog and stops

    4. None of other DEV/SIT/the other QA server has this issue till now

     

    Kindly let me know if someone has any clue on this.

     

    Tx & Regards
    Sankar B

     

    Error:

    EventType clr20r3, P1 processhost.exe, P2 1.0.0.0, P3 47eb4421, P4 mscorlib, P5 2.0.0.0, P6 461eee3d, P7 331e, P8 26d, P9 system.io.ioexception, P10 NIL.

    Monday, May 5, 2008 4:20 PM
  • I have the same error with application what use deserialize, the application close without error.

    You have a solution for the problem?


    GEMA INFORMATICA
    Thursday, February 26, 2009 3:45 PM
  • Hi all,

    I got the same error!

    "EventType clr20r3, P1 6570636E76D163A7670D52A17A0B5E8F, P2 1.0.0.0, P3 4c9ea13a, P4 mscorlib, P5 2.0.0.0, P6 4be90358, P7 e1, P8 16, P9 system.argumentoutofrange, P10 NIL."

    Tuesday, September 28, 2010 3:02 AM
  • Hi Amar,

    Did you find any solution to this? I have encountered a very similar situation except that the message is outofmemoryexception instead of ioexception. All other things are exactly as you said. Kindly share if you found a solution.

    Wednesday, April 13, 2011 8:58 AM