none
How to use FM20.DLL lower version file in applications that are running on higher versions of FM20.dll RRS feed

  • Question

  • Hi,

    I have one application that i have developed using FM20.DLL with version 15.0.4687.100 (64x bit operating system)

    And my end customer have applications with lower FM20.dll files (14.0.6009.1000), and customer dont want to upgrade there system to newer files.

    During restoring backup,

    CUSTOMER IS GETTING FOLLOWING ERROR:

    "MICROSOFT fORMS 2.0 COMBOBOX : Newer files version of activex Control Required"

    so how can i implement this?

    or i need to develop it again by using older FM20.dll file?

    is there any solution?

    Tuesday, October 18, 2016 8:34 AM

Answers

  • Hi Vikram,

    >>my end customer have applications with lower FM20.dll files (14.0.6009.1000), and customer dont want to upgrade there system to newer files.

    You can't use a file created in a lower version than the one you're using.

    depending on versions...  there will be restrictions and errors  are expected.

    I think it is the same as .net 4.5 compatibility with 4.0

    The .NET Framework 4.5 and its point releases (4.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2) are backward-compatible with apps that were built with earlier versions of the .NET Framework. In other words, apps and components built with previous versions will work without modification on the .NET Framework 4.5.

    >>or i need to develop it again by using older FM20.dll file?

    It is not compatible on higher version. As it stands now, higher version cannot be executed on a lower version. Actually, update your customer system to newer files will be good choice. As a seller, please try to persuade your customers.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.




    • Edited by Kristin Xie Wednesday, October 19, 2016 1:47 AM
    • Proposed as answer by Kristin Xie Monday, October 24, 2016 8:24 AM
    • Marked as answer by Vikram Lokhande Thursday, January 19, 2017 12:15 PM
    Wednesday, October 19, 2016 1:42 AM

All replies

  • Hi Vikram,

    >>my end customer have applications with lower FM20.dll files (14.0.6009.1000), and customer dont want to upgrade there system to newer files.

    You can't use a file created in a lower version than the one you're using.

    depending on versions...  there will be restrictions and errors  are expected.

    I think it is the same as .net 4.5 compatibility with 4.0

    The .NET Framework 4.5 and its point releases (4.5.1, 4.5.2, 4.6, 4.6.1, and 4.6.2) are backward-compatible with apps that were built with earlier versions of the .NET Framework. In other words, apps and components built with previous versions will work without modification on the .NET Framework 4.5.

    >>or i need to develop it again by using older FM20.dll file?

    It is not compatible on higher version. As it stands now, higher version cannot be executed on a lower version. Actually, update your customer system to newer files will be good choice. As a seller, please try to persuade your customers.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.




    • Edited by Kristin Xie Wednesday, October 19, 2016 1:47 AM
    • Proposed as answer by Kristin Xie Monday, October 24, 2016 8:24 AM
    • Marked as answer by Vikram Lokhande Thursday, January 19, 2017 12:15 PM
    Wednesday, October 19, 2016 1:42 AM
  • Thank you Kristin Xie

    Really appreciate.


    VRV

    Thursday, January 19, 2017 12:15 PM