locked
RSA SecurID RRS feed

  • Question

  • Has anyone tried to secure communication using an RSA securID?  If so, how did you do it?  I have an ugly solution in place but want to make it more standard.

    Tuesday, May 6, 2008 4:31 PM

Answers

  • I've just found that if you start the SecurID application using Vista's "Run As Administrator.." option the application will start and I don't get the "Error in TKN library" message.  Hope this helps.

    Ray
    Sunday, September 14, 2008 2:58 AM

All replies

  • I have but I constanly have to uninstall and reinstall to make work but after reboot have to repeat the steps can you share your solution?

    (Fail to open token service.:Error in TKN libraryStick out tongueassword validation failed )
    Saturday, May 17, 2008 12:02 PM
  •  

    Can you share your solution every time I reboot my Vista box I get the following error so I have to uninstall reinstall import the token and it works but have to repeat these steps every time I reboot.  Can you share your solution?

    (fail to open token service.:Error in TKN libraryStick out tongueassword validation failed)

    Saturday, May 17, 2008 12:23 PM
  •  

    Hi,  I have the same problem. Anyone found any solution. Please let me know.

     

    Thanks,

    Mani.

    Tuesday, May 20, 2008 2:56 PM
  • My solution is just to put the credentials in the RST to my STS and and make the call from the STS to perform the authentication.  The more standard way of doing it is to secure the actual channel to the STS with the SecurID credentials, but I can't figure out a good way to do it.  Thoughts?

     

    Thursday, May 29, 2008 2:32 PM
  • Has anyone found a solution to this yet?

    Monday, June 9, 2008 7:08 PM
  • I found that when i deleted all of my TAP-Win32 virtual ethernet adapters it solved this problem... Hope it helps!
    Monday, June 23, 2008 11:57 AM
  • how can i delete all of my TAP-Win32??
    Thank's
    Monday, July 28, 2008 3:43 PM
  • Well, in windows there is an option to do so within the OpenVPN/utilities option on the start menu...
    • Proposed as answer by BiswajitBhuyan Thursday, July 9, 2009 10:42 PM
    Thursday, July 31, 2008 10:29 AM
  • I've just found that if you start the SecurID application using Vista's "Run As Administrator.." option the application will start and I don't get the "Error in TKN library" message.  Hope this helps.

    Ray
    Sunday, September 14, 2008 2:58 AM
  • The easiest way to go is to delete the SoftwareToken.DB file in the installation directory and import the token again.
    • Proposed as answer by BiswajitBhuyan Thursday, July 9, 2009 10:47 PM
    Thursday, July 9, 2009 10:47 PM
  • I finally resolved the problem.  Look at the directory
    C:\Program Files\RSA Security\RSA SecurID Software Token
    If you have the file:
    SoftwareTokens.DB
    rename it to:
    SoftwareTokens.old

    This resolved my problem and I was then able to run the RSA SecurID Software Token.
    Wednesday, January 20, 2010 4:04 AM
  • did not work for me.. I renamed, deleted, and reinstalled and it still came up with the error in windows 7.

    But I did run Easy Transfer Tool to get my profile from another windows 7 machine (it worked for a couple of weeks).

    what i did was go to:

    C:\Users\Username\AppData\Local\VirtualStore\Program Files\RSA Security\RSA SecurID Software Token

    and delete the SoftwareTokens.DB

    as well as the normal place...C:\Program Files\RSA Security\RSA SecurID Software Token...

    I found that in Windows 7 Pro it stored them in two places..

    Anyway, thought I would update this to help if anyone can't seem to get it to work..

    Monday, May 7, 2012 3:10 PM
  • Hi Guys,

    Window 7 users need to go to regedit->HKEY_LOCAL_MACHINE\SOFTWARE\RSA Security\RSA SecurID Software Token\3.0\SecurID to rename SoftwareTokens.DB to SoftwareTokens.old.

    It worked for me.

    Have Fun and Cheers

    Thursday, December 19, 2013 3:32 PM