none
How to connect to the oracle remote server using .Net Providers? RRS feed

  • Question

  • I have installed oracle client still i am getting an error saying " System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. " wht might be the issue? pls help.
    Shashank
    • Moved by Harry Zhu Thursday, August 20, 2009 3:44 AM relating to oracle provider (From:Visual C# Language)
    Wednesday, August 19, 2009 4:37 AM

Answers

  • Solution Description
    --------------------

    Oracle 9.2 Client software requires that you give the Authenticated User
    privilege to the Oracle Home by following these steps:

    1. Log on to Windows as a user with Administrator privileges.

    2. Launch Windows Explorer from the Start Menu and and navigate to the
    ORACLE_HOME folder. This is typically the "Ora92" folder under the
    "Oracle" folder (i.e. D:\Oracle\Ora92).

    3. Right-click on the ORACLE_HOME folder and choose the "Properties" option
    from the drop down list. A "Properties" window should appear.

    4. Click on the "Security" tab of the "Properties" window.

    5. Click on "Authenticated Users" item in the "Name" list (on Windows XP
    the "Name" list is called "Group or user names").

    6. Uncheck the "Read and Execute" box in the "Permissions" list under the
    "Allow" column (on Windows XP the "Permissions" list is called
    "Permissions for Authenticated Users").

    7. Re-check the "Read and Execute" box under the "Allow" column (this is
    the box you just unchecked).

    8. Click the "Advanced" button and in the "Permission Entries" list make
    sure you see the "Authenticated Users" listed there with:

    Permission = Read & Execute
    Apply To = This folder, subfolders and files

    If this is NOT the case, edit that line and make sure the "Apply onto"
    drop-down box is set to "This folder, subfolders and files". This
    should already be set properly but it is important that you verify this.

    9. Click the "Ok" button until you close out all of the security properties
    windows. The cursor may present the hour glass for a few seconds as it
    applies the permissions you just changed to all subfolders and files.

    10. Reboot your computer to assure that these changes have taken effect.


    http://thedotnet.com/nntp/451661/showpost.aspx
    Life would have been much easier if I had the source-code !!
    • Marked as answer by Yichun_Feng Wednesday, August 26, 2009 1:26 AM
    Wednesday, August 19, 2009 4:42 AM

All replies

  • Solution Description
    --------------------

    Oracle 9.2 Client software requires that you give the Authenticated User
    privilege to the Oracle Home by following these steps:

    1. Log on to Windows as a user with Administrator privileges.

    2. Launch Windows Explorer from the Start Menu and and navigate to the
    ORACLE_HOME folder. This is typically the "Ora92" folder under the
    "Oracle" folder (i.e. D:\Oracle\Ora92).

    3. Right-click on the ORACLE_HOME folder and choose the "Properties" option
    from the drop down list. A "Properties" window should appear.

    4. Click on the "Security" tab of the "Properties" window.

    5. Click on "Authenticated Users" item in the "Name" list (on Windows XP
    the "Name" list is called "Group or user names").

    6. Uncheck the "Read and Execute" box in the "Permissions" list under the
    "Allow" column (on Windows XP the "Permissions" list is called
    "Permissions for Authenticated Users").

    7. Re-check the "Read and Execute" box under the "Allow" column (this is
    the box you just unchecked).

    8. Click the "Advanced" button and in the "Permission Entries" list make
    sure you see the "Authenticated Users" listed there with:

    Permission = Read & Execute
    Apply To = This folder, subfolders and files

    If this is NOT the case, edit that line and make sure the "Apply onto"
    drop-down box is set to "This folder, subfolders and files". This
    should already be set properly but it is important that you verify this.

    9. Click the "Ok" button until you close out all of the security properties
    windows. The cursor may present the hour glass for a few seconds as it
    applies the permissions you just changed to all subfolders and files.

    10. Reboot your computer to assure that these changes have taken effect.


    http://thedotnet.com/nntp/451661/showpost.aspx
    Life would have been much easier if I had the source-code !!
    • Marked as answer by Yichun_Feng Wednesday, August 26, 2009 1:26 AM
    Wednesday, August 19, 2009 4:42 AM
  • Hi Shashank Saudagar,

     

    You can use this connection string to connect Oracle remotely:

    Data Source=TORCL;User Id=myUsername;Password=myPassword;

    The data source is configured in the Oracle Net Manager which is included in Oracle

    Home.

     

    For the configuration of Oracle, you can better help if you post in Oracle related support forums.

     

    Best Regards

    Yichun Feng

    Thursday, August 20, 2009 9:22 AM