none
How to build for .net 1.1 on VS 2005 RRS feed

  • Question

  • I've been searching and not finding the answer I'd like.  8-(

     

    I built a nice C# application that I'm having problems running.  I used VS 2005 (.net 2.0), and the target system complains .net 2.0 is needed, since it only has .net 1.1.  My development system has both 1.1 and 2.0 installed.

     

    I don't have access to VS 2003 to get apps with 1.1.  I don't want to require the target to have 2.0 installed.

     

    I tried <supportedRuntime>, in a config file, but this doesn't seem to be working (or I don't understand how to do it - pointers appreciated).  The documentation only talks about using this for 1.0 and 1.1, 2.0 or beyond aren't discussed - can't tell if they're supported.  I"m assuming that creating this file will effect the build, which it isn't.  I'm using <app>.exe.config (replace <app> with the image name).

     

    The output window from the build shows /reference qualifiers going to 2.0 specific directories.  The 1.1 equivalents exist on my system, but I don't see if there is a way to change them to use 1.1?

     

    I saw mention of MSBuild compatibility tool, but it doesn't seem to have been updated since 2005; nor supported.

     

    Without a workaround for this, I will probably be forced to abandon C# and go back to V C++ which won't have these .net issues.

     

    Thanks for any help!

     

    Friday, April 18, 2008 4:12 PM

Answers

All replies

  • Have you tried this?

     

    Sunday, April 20, 2008 6:42 PM
    Moderator
  • See if I can reply this time...  browser keeps saying error, and not posting...

     

    I'll take a look thanks.  I was hoping for more officially supported way to do this, but I guess will take what might work instead...

    Monday, April 21, 2008 12:29 PM
  • >http://weblogs.asp.net/israelio/archive/2005/06/08/410811.aspx

     

    This didn't work for me.  I notice that posting hasn't been updated by Ohad since 2005.  The blog said that they were going to post a forms example; which is the case I have, so maybe that's why this case didn't work for me.

     

    I got up to step 8, but I had additional build errors:

     

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets : warning MSB3247: Found conflicts between different versions of the same dependent assembly.

     

    (and a few others...)

     

    This looks due to the csc command I see in the Output window:

     

    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322 Csc.exe /noconfig ... /reference:C:\WINDOWS\assembly\GAC_MSIL\System.Deployment\2.0.0.0__b03f5f7f11d50a3a\System.Deployment.dll ...

     

    With mostly other V1.1 references.  I could guess that V1.1 and V2.0 won't mix.  I can't find a System.Deployment file in the V1.1 directories on my system.

     

    Other ideas?  I'm getting the idea that people just aren't trying this.  That if you use VS 2005, you also must use V2.0.

    Tuesday, April 22, 2008 6:22 PM