locked
adding asp.vb web page to existing web site RRS feed

  • Question

  • User-1746619733 posted

    I have had a web site up and running for a few years. Itis designed in vb.net/asp. I have recently added a few web pages to the project. They will run on my machine in local host but when upload it to my web site I have trouble viewing it. I have used FTP commander to transfer the pages from my C:\Inetpub\wwwroot\mywebsite to the web server. I am getting the following error when I try to access the new page.

     

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load type 'CSC.TestWeightReports'.

    Source Error:

    Line 2:  <%@ Register TagPrefix="uc1" TagName="userFoot" Src="userFoot.ascx" %>
    Line 3:  <%@ Register TagPrefix="uc1" TagName="userHead" Src="userHead.ascx" %>
    Line 4:  <%@ Page Language="vb" AutoEventWireup="false" Codebehind="TWC.aspx.vb" Inherits="CSC.TestWeightReports"%>
    Line 5:  <!doctype html public "-//w3c//dtd html 4.0 transitional//en">
    Line 6:  <HTML xmlns:o>


    Source File: F:\users\www.mywebsite.com\doc\twc.aspx    Line: 4

    Can anyone help me. I am lost at this point trying to figure out what is wrong. Thanks,

     

    Jason


    Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.

     

    Tuesday, August 29, 2006 4:29 PM

Answers

  • User-524013004 posted

    As it has built a few years ago, The presumption is that your site is running dot.net 1.1 and that you have a single assembly for all page classes - not always true but highly likely here.

    Did you copy the newly compiled dll from the bin folder on your local machine to the remote site - or ensure that your FTP settings do not enforce a rule that prevents the files replacement /update?

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 30, 2006 1:05 AM

All replies

  • User-1936260519 posted

    Hi,

     what are the namespace and class name defined in TWC.aspx.vb

    Wednesday, August 30, 2006 12:13 AM
  • User-524013004 posted

    As it has built a few years ago, The presumption is that your site is running dot.net 1.1 and that you have a single assembly for all page classes - not always true but highly likely here.

    Did you copy the newly compiled dll from the bin folder on your local machine to the remote site - or ensure that your FTP settings do not enforce a rule that prevents the files replacement /update?

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 30, 2006 1:05 AM
  • User-524013004 posted
    The presumption made previously is that if you are asking this question that you have not adjusted the default application namespace (on your machine the site is CSS) and have not added namespace statements to your code behind class(s).
    Wednesday, August 30, 2006 1:09 AM
  • User-1746619733 posted

    thank you very much. I copied the .dll over and that fixed the problem.

     

    thanks,

     

    Jason

    Wednesday, August 30, 2006 7:32 AM