locked
IIS hosted WCF virtual application at '/*' is shutting down RRS feed

  • Question

  • User992810919 posted

    Hi,
    I am getting the below error intermittently. This is WCF exposed to Clients. Has separate AppPool. We have changed few setting like multipleSiteBindingsEnabled already, with no luck.

    WebHost failed to process a request.
     Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/1349301
     Exception: System.ServiceModel.ServiceActivationException: Request to the service at '~/Service.svc' cannot be dispatched because the virtual application at '/GEN' is shutting down. ---> System.InvalidOperationException: Request to the service at '~/Service.svc' cannot be dispatched because the virtual application at '/GEN' is shutting down.
       --- End of inner exception stack trace ---
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.FailActivationIfRecyling(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath, EventTraceActivity eventTraceActivity)
     Process Name: w3wp
     Process ID: 4456
    WebHost failed to process a request.
     Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/45051907
     Exception: System.ServiceModel.ServiceActivationException: The service '/CSP/Service.svc' cannot be activated due to an exception during compilation.  The exception message is: This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection. If your service is being hosted in IIS you can fix the problem by setting 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true or specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.
    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection. If your service is being hosted in IIS you can fix the problem by setting 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true or specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.
    Parameter name: item
       at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)
       at System.Collections.Generic.SynchronizedCollection`1.Add(T item)
       at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)
       at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)
       at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)
       at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
       --- End of inner exception stack trace ---
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath, EventTraceActivity eventTraceActivity)
     Process Name: w3wp
     Process ID: 20088

    Wednesday, December 21, 2016 11:06 AM

All replies

  • User-2057865890 posted

    Hi Rajesh,

    In my opinion the biggest source of problems in IIS configurations is Application Pool Recycling. 

    Application Pool Idle Timeout

    IIS will shut down an app pool after 20 minutes of inactivity.
    Make sure you disable the Process Model IdleTimeout for your app pools.
    Unless you have lots of app pools and heavy memory pressure, you should always set this to 0.

    Regular Time Interval

    The default is 1740 minutes, every 29 hours the App Pool will recycle, regardless of activity. You don’t want that happening, set this to 0.

    Besides, this thread is related to IIS forum, so please post thread on that forum for more effective response. 

    Best Regards,

    Chris

    Thursday, December 22, 2016 12:52 PM
  • User992810919 posted

    Hi Chris,
    I will try the suggested options. Though, I don't understand why this message would be in Error type in windows logs, event viewer?

    It should be simply info level event.

    Friday, December 23, 2016 4:48 AM
  • User-2057865890 posted

    Hi Rajesh,

    Though, I don't understand why this message would be in Error type in windows logs, event viewer?

    It should be simply info level event.

    IIS event messages are recorded in the Application log of the Windows Event Viewer.

    https://msdn.microsoft.com/en-us/library/ms524718(v=vs.90).aspx

    Best Regards,

    Chris

    Wednesday, December 28, 2016 9:19 AM