none
Unable to create Integration Services Catalog

Answers

  • If you install the Integration Service the CLR should be enabled by default. Or not?

    Nope

    You've to get it enabled

    like this

    EXEC sp_configure 'clr enabled' , '1';  
    RECONFIGURE;   


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Monday, February 12, 2018 10:45 AM
  • Hi DIEGOCTN,

    The common language runtime(CLR) integration feature is off by default, and must be enabled in order to use objects that are implemented using CLR integration.

    You can check the Enable CLR Integration in Create Catalog Wizard.

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by DIEGOCTN Tuesday, February 13, 2018 10:27 AM
    Tuesday, February 13, 2018 9:38 AM

All replies

  • My SSMS's version is 2012. Could it be this the problem?

    Hello,

    Could be, better use the latest SSMS version: Download SQL Server Management Studio (SSMS)


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, February 09, 2018 5:34 PM
  • I did. Now the error is different:

    It looks that the service has not been installed (unfortunately I cannot check). 

    Friday, February 09, 2018 5:43 PM
  • I did. Now the error is different:

    It looks that the service has not been installed (unfortunately I cannot check). 

    As per below discussion it seems like multiple reasons can cause it

    like

    1. Not using same version of SSMS as your SQLServer version to create catalog

    2. Integration Services feature not installed

    3. user running the SSMS has no access to the path where the .bak file resides (the path is in Program Files)

    Please check and see if any of specified solution fixes your issue

    https://dba.stackexchange.com/questions/77247/not-able-to-create-ssisdb-catalog


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Friday, February 09, 2018 6:21 PM
  • Hi guys, 

    I am checking the server and I found out that I am missing the DTS folder (C:\\Program Files\Microsoft SQL Server\130). I guess this is the reason. 

    Any thoughts?

    Monday, February 12, 2018 9:48 AM
  • No Integration Services installed.
    Monday, February 12, 2018 10:04 AM
  • No Integration Services installed.

    Then you've to get it installed first before you setup Integration Services Catalog

    Also CLR has to be enabled at the instance level before you setup catalog


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Monday, February 12, 2018 10:11 AM
  • If you install the Integration Service the CLR should be enabled by default. Or not?
    Monday, February 12, 2018 10:36 AM
  • If you install the Integration Service the CLR should be enabled by default. Or not?

    Nope

    You've to get it enabled

    like this

    EXEC sp_configure 'clr enabled' , '1';  
    RECONFIGURE;   


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Monday, February 12, 2018 10:45 AM
  • Hi DIEGOCTN,

    The common language runtime(CLR) integration feature is off by default, and must be enabled in order to use objects that are implemented using CLR integration.

    You can check the Enable CLR Integration in Create Catalog Wizard.

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by DIEGOCTN Tuesday, February 13, 2018 10:27 AM
    Tuesday, February 13, 2018 9:38 AM