locked
Error running Random Forest from R RRS feed

  • Question

  • I am running a fairly length R script.  When I get to this line, an exception is thrown:

    randomForest1 <- randomForest(Post_Imp_Def_Ind~., data=impute1, importance=TRUE, norm.votes=FALSE)

    When I check the output log, I get the following message

    [ModuleOutput]   DllModuleHost S
    [ModuleOutput]   DllModuleHost Error: 1 : Program::Main encountered fatal exception: Microsoft.Analytics.Exceptions.ErrorMapping+ModuleException: Error 0063: The following error occurred during evaluation of R script:
    [ModuleOutput] ---------- Start of error message from R ----------
    [ModuleOutput] R script execution failed. Please click on "View Output Log" in the properties pane for full details.
    [ModuleOutput] ----------- End of error message from R -----------
    Module finished after a runtime of 00:00:34.7720217 with exit code -2
    Module failed due to negative exit code of -2

    I verified that I included the randomForest module in the beginning of the script

    require(randomForest)

    I did notice in the output that some of the other CRAN modules that I reference are also not being added

    [ModuleOutput] In addition: Warning messages:
    [ModuleOutput] 
    [ModuleOutput] 1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE,  :
    [ModuleOutput] 
    [ModuleOutput]   there is no package called 'AUC'
    [ModuleOutput] 
    [ModuleOutput] 2: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE,  :
    [ModuleOutput] 
    [ModuleOutput]   there is no package called 'pROC'
    [ModuleOutput] 

    What else do I need to do to add these modules?

    Thanks

    Sunday, September 28, 2014 12:31 AM

Answers

  • Hello Jamie,

    Thank you for bringing this to our attention. We will try and get AUC and pROC into our R distribution so you do not need to install them separately.

    • Marked as answer by Jamie.DixonMVP Tuesday, September 30, 2014 12:03 PM
    Monday, September 29, 2014 1:17 PM
  • Never mind

    I found this post that shows me how to upload the packages

    http://blogs.msdn.com/b/benjguin/archive/2014/09/24/how-to-upload-an-r-package-to-azure-machine-learning.aspx

    • Marked as answer by Jamie.DixonMVP Tuesday, September 30, 2014 12:04 PM
    Sunday, September 28, 2014 1:19 AM

All replies

  • I found the answer, somewhat

    I looks like AUC and pROC is not available on Azure ML.

    Can these be added?  If not, is there an available package that is an equivalent?

    Thanks

    Sunday, September 28, 2014 1:12 AM
  • Never mind

    I found this post that shows me how to upload the packages

    http://blogs.msdn.com/b/benjguin/archive/2014/09/24/how-to-upload-an-r-package-to-azure-machine-learning.aspx

    • Marked as answer by Jamie.DixonMVP Tuesday, September 30, 2014 12:04 PM
    Sunday, September 28, 2014 1:19 AM
  • Hello Jamie,

    Thank you for bringing this to our attention. We will try and get AUC and pROC into our R distribution so you do not need to install them separately.

    • Marked as answer by Jamie.DixonMVP Tuesday, September 30, 2014 12:03 PM
    Monday, September 29, 2014 1:17 PM