none
How to Fix Runtime Error 3197 in Microsoft Access 2010? RRS feed

  • Question

  • Hi Fellas,

    It's been quite a while since this pop up "the microsoft access database engine stopped the process because you and another user are attempting to change the same data at the same time" keeps showing up on my newly created Access database, whenever I'm trying to access my table I created lately. Already tried "Compact& Repair" but no success. Please provide appropriate solution.

    Regards,
    Bruce Anderson


    Monday, July 23, 2018 12:33 PM

All replies

  • Hi Bruce,

    You may find this useful: http://www.utteraccess.com/forum/run-time-error-3197-t1952450.html  which states:

    'I followed these recommendations and problem solved
    http://bugs.mysql.com/bug.php?id=46761
    http://dev.mysql.com/doc/refman/5.1/en/con...icrosoft-access
    added a column "Last_change" TimeStamp with default "CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP"
    I also updated the DNS and checked the "Return matching rows"
    don't know which of them did the trick but so far it is working'


    Ian Broadbent

    Monday, July 23, 2018 11:02 PM
  • Hi Bruce,

    This forum focuses on general discussion for Office 365 ProPlus. I notice your issue is related to Access database. To better fix the issue, I move the thread to Access forum for more suggestion.

    Thanks for your understanding.


    Best Regards,
    Winnie Liang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, July 24, 2018 6:42 AM
  • Hello BruceA10,

    Have you tried to repair your office instead of repairing the database file? Does your Office newly installed or has worked and get this issue recently? 

    The latest version for Office 2010 is 14.0.7211.5000. What's the building number of your office? If it is not the latest version, please try to update to latest version.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, July 25, 2018 9:08 AM
  • Is this happening in a standalone database, which is not shared by any other users? 

    Is this a local table, stored within the .accdb file, or is it a linked table?

    How are you accessing the data?  Are you opening the table directly as a datasheet, or are you doing it via a form?  If via a form, is there any code behind that form?

    Just to eliminate one possibility, have you rebooted your computer since this started happening?


    Dirk Goldgar, MS Access MVP
    Access tips: www.datagnostics.com/tips.html

    Wednesday, July 25, 2018 5:12 PM
  • I recently encountered this error, in my case I was trying to do the following:

    1. Toggle a checkbox from FALSE to TRUE or vice-versa.
    2. Upon update (or click) check the contents of the checkbox and input the date into another field within the same table as the checkbox field if TRUE or update the field to Null if FALSE.

    So the form containing the checkbox is bound to the table containing both the checkbox fields and the fields to contain the relevant dates or null values. 

    Anyhow, if someone encounters the same issue then try placing DoCmd.RefreshRecord at the start of your sub. Essentially, in my case, the table was trying to update two fields simultaneously or near-simultaneously with some added latency due to the front and back-end being split. The DoCmd.RefreshRecord worked as a wait timer with the added benefit of ensuring the determination of TRUE or FALSE was accurate.

    Just thought I'd add this as I found this topic whilst looking for an answer.

    Thursday, April 25, 2019 12:06 PM