none
.NET 3.5 SP1 installation failed RRS feed

  • Question

  • I'm trying to install U2U CAML Query Builder in XP Pro SP3 and I have .NET 2 SP2 installed. Here's my install log:

    The following properties have been set:
    Property: [AdminUser] = true {boolean}
    Property: [ProcessorArchitecture] = Intel {string}
    Property: [VersionNT] = 5.1.3 {version}
    Running checks for package 'Windows Installer 3.1', phase BuildList
    The following properties have been set for package 'Windows Installer 3.1':
    Running checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe'
    Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '3.1': true
    Result of checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe' is 'Bypass'
    'Windows Installer 3.1' RunCheck result: No Install Needed
    Running checks for package '.NET Framework 3.5 SP1', phase BuildList
    Reading value 'SP' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5'
    Unable to read registry value
    Not setting value for property 'DotNet35SP'
    The following properties have been set for package '.NET Framework 3.5 SP1':
    Running checks for command 'DotNetFX35SP1\dotNetFx35setup.exe'
    Skipping ByPassIf because Property 'DotNet35SP' was not defined
    Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false
    Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.1.2': false
    Result of running operator 'VersionEqualTo' on property 'VersionNT' and value '5.2.0': false
    Result of running operator 'ValueEqualTo' on property 'ProcessorArchitecture' and value 'IA64': false
    Result of checks for command 'DotNetFX35SP1\dotNetFx35setup.exe' is 'Install'
    '.NET Framework 3.5 SP1' RunCheck result: Install Needed
    EULA for components '.NET Framework 3.5 SP1' was accepted.
    Copying files to temporary directory "C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\"
    Downloading files to "C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\"
    (3/6/2010 6:58:49 PM) Downloading 'DotNetFX35SP1\dotNetFx35setup.exe' from 'http://go.microsoft.com/fwlink/?linkid=118076' to 'C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\'
    Download completed at 3/6/2010 6:58:55 PM
    Verifying file integrity of C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\DotNetFX35SP1\dotNetFx35setup.exe
    WinVerifyTrust returned 0
    File trusted
    Running checks for package '.NET Framework 3.5 SP1', phase BeforePackage
    Reading value 'SP' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5'
    Unable to read registry value
    Not setting value for property 'DotNet35SP'
    The following properties have been set for package '.NET Framework 3.5 SP1':
    Running checks for command 'DotNetFX35SP1\dotNetFx35setup.exe'
    Skipping ByPassIf because Property 'DotNet35SP' was not defined
    Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false
    Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.1.2': false
    Result of running operator 'VersionEqualTo' on property 'VersionNT' and value '5.2.0': false
    Result of running operator 'ValueEqualTo' on property 'ProcessorArchitecture' and value 'IA64': false
    Result of checks for command 'DotNetFX35SP1\dotNetFx35setup.exe' is 'Install'
    '.NET Framework 3.5 SP1' RunCheck result: Install Needed
    Verifying file integrity of C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\DotNetFX35SP1\dotNetFx35setup.exe
    WinVerifyTrust returned 0
    File trusted
    Installing using command 'C:\DOCUME~1\TDELPR~1\LOCALS~1\Temp\VSD20A.tmp\DotNetFX35SP1\dotNetFx35setup.exe' and parameters ' /lang:enu /passive /norestart'
    Process exited with code 1603
    Status of package '.NET Framework 3.5 SP1' after install is 'InstallFailed'


    Beat the Blog
    Sunday, March 7, 2010 12:11 AM

Answers

  • Hi Pichapie,

    Based on your description, it seems that you have some concern on installing .NET Framework 3.5 on your Windows XP machine.

    For error code "1603", it's a common error message which means "fatal error during installation". For further troubleshooting, we need to look into the log files to track the root cause of your concern.

    Could you please help me to try the following points?

    Before the installation, please update your OS and ensure that there is no pre-release component installed on your machine. Please sign in with Administrator Privilege to install .NET Framework 3.5.

    Then please:

    1. Use Cleanup tool to clear .NET Framework 3.5 >> 3.0 >> 2.0 in order
    2. Separately download .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
    2. Run the installer to install .NET Framework 3.5 with SP1 (Full Package)
    3. If any problem occurs during the installation, use try these steps to apply Collect tool to collect the log files.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 3.5 with SP1 (Full Package)
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, March 12, 2010 2:16 AM
    Monday, March 8, 2010 3:44 AM

All replies

  • Hi Pichapie,

    Based on your description, it seems that you have some concern on installing .NET Framework 3.5 on your Windows XP machine.

    For error code "1603", it's a common error message which means "fatal error during installation". For further troubleshooting, we need to look into the log files to track the root cause of your concern.

    Could you please help me to try the following points?

    Before the installation, please update your OS and ensure that there is no pre-release component installed on your machine. Please sign in with Administrator Privilege to install .NET Framework 3.5.

    Then please:

    1. Use Cleanup tool to clear .NET Framework 3.5 >> 3.0 >> 2.0 in order
    2. Separately download .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
    2. Run the installer to install .NET Framework 3.5 with SP1 (Full Package)
    3. If any problem occurs during the installation, use try these steps to apply Collect tool to collect the log files.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 3.5 with SP1 (Full Package)
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, March 12, 2010 2:16 AM
    Monday, March 8, 2010 3:44 AM
  • Hi Pichapie,

    Does the above suggestion work?

    If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, March 10, 2010 5:06 AM
  • Hi Pichapie,

    I've marked my reply as answer. If you have any concern, you can unmark my reply and let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, March 12, 2010 2:16 AM