locked
ASp.net 4 with IIS 6 on windows server 2003 Sp2 RRS feed

  • Question

  • User1658618692 posted

    I developed a website and wanted to publish on out server 2003 sp2. As it did not have .Net Framework 4.0 I downloaded and Installed it.

    My website target ASP.NET framework 4.0 on my Dev machine. I created website on Production server But when I right click and go to properties asp.net version 4.0 does not get listed under asp.net tab for my website properties.  I found on forum that I have to run aspnet_regiis -s "W3SVC/'site Identifier"/ROOT" command. Though I could not find aspnet_regiis under v4.0.30319. I am not sure how do I register my website.

     Any suggestion. Thanks in advance. 

    Tuesday, December 13, 2011 4:46 PM

Answers

  • User-1672167363 posted

    Hi,

    You need to install the Client and Extended Full Dot Net 4.0 Framework the Stand-Alone installer is for X86 and X64.

    Did you read the Net 4.0 readme notes : http://go.microsoft.com/fwlink/?LinkID=186763 .

    The Client / Extended  installer(s)  will create the folders and update with the correct framework tools.

    Martin

     

     

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, December 14, 2011 10:53 AM

All replies

  • User-1672167363 posted

    Hello,

    Can you provided more information about the Server 2003 SP2 system X86 X64 ?

    "Developed a website and wanted to publish to server 2003 sp2"

    Net 4.0 Framework you installed both  client and extended http://msdn.microsoft.com/en-us/netframework/aa569263 ?

     "I could not find aspnet_regiis under v4.0.30319."  "I am not sure how do I register my website."

    Need more information to explain why this has not worked..

    Martin

     

    Tuesday, December 13, 2011 6:37 PM
  • User1658618692 posted

     Thank you for your reply.

     It is a X86 System with Windows server 2003 SP2. Do I need to download .Net Framework from the link you specified? I already have C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319 this folder available on my machine. Please let me know.

     

    Wednesday, December 14, 2011 7:48 AM
  • User-620729683 posted

    If aspnet_regiis is missing under v4 folder then it seems .net 4 is not installed correctly OR not correctly registered on server itself try to reinstall .net 4,

    Use .net removal tool to remove .net 4 URL and reinstall .net 4

    Wednesday, December 14, 2011 10:48 AM
  • User-1672167363 posted

    Hi,

    You need to install the Client and Extended Full Dot Net 4.0 Framework the Stand-Alone installer is for X86 and X64.

    Did you read the Net 4.0 readme notes : http://go.microsoft.com/fwlink/?LinkID=186763 .

    The Client / Extended  installer(s)  will create the folders and update with the correct framework tools.

    Martin

     

     

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, December 14, 2011 10:53 AM
  • User1658618692 posted

     Yes that worked. Initially I had .Net framework 4.0 Client profile only and that did not have all the components I needed. Now I installed full .net framework 4.0 and it has all files.

     Thank you all for your help.

    Wednesday, December 14, 2011 2:03 PM