none
can't install dotnet 4.5 RRS feed

  • Question

  • I can't install dotnet 4.5 since i have 4.7 can you provide a link for source.iso for installing it as like dotnet 3.5
    Sunday, April 1, 2018 7:36 AM

All replies

  • Yes you can do that :) 

    Read this specific blog,

    Downgrade dotnet version


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (kokkisajee) or Facebook (sajeetharan) profile for Sajeetharan at Stack Overflow, Q&A for professional and enthusiast programmers

    Sunday, April 1, 2018 7:46 AM
  • Hi friend,

    Welcome to the MSDN forum.

    What’s your OS version?

    Please have a look at this docs: .NET Framework Versions and Dependencies and Install the .NET Framework for developers, it provides links for installing all versions of the .Net Framework from 4.5 to 4.7.1.

    All .NET Framework versions since .NET Framework 4 are in-place updates, so only a single 4.x version can be present on a system. In addition, particular versions of the .NET Framework are pre-installed on some versions of the Windows operating system. This means that:

    1. If there's a later 4.x version installed on the machine already, you can't install a previous 4.x version.
    2. If the OS comes pre-installed with a particular .NET Framework version, you can't install a previous 4.x version on the same machine.
    3. If you install a later version, you don't have to first uninstall the previous version.

    Due to the above documentation, it seems you cannot install the.NET Framework 4.5 since you already installed the higher version 4.7. If the .NET Framework 4.7 is not shipped with your OS, you can try to uninstall it, then install the .NET Framework 4.5. After that, re-install the .NET Framework 4.7.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, April 2, 2018 2:51 AM
    Moderator
  • I have windows 10 pro and i resetted my pc the day before yesterday then it went for critical update.

    When I looked for the dotnet version installed in my pc , I found it to be 4.7 . But I installed .net 3.5 by

    mounting an iso . I thaught you may have an iso file for v4.5 also . Thanks for your reply .

    Tuesday, April 3, 2018 7:37 AM
  • Thanks for your reply, but it didn't help me.I have .net version 4.7 which is not mentioned in the link above.

    Tuesday, April 3, 2018 7:41 AM
  • Hi friend,

    Thank you for your confirmation, it seems the .Net Framework 4.7 is shipped with the Windows 10 and refer to my previous reply, you cannot install a previous 4.x version on the same machine.

    Because of the .Net Framework 3.5 is built with a lower CLR 2.0 version and the .NET Framework 4, 4.5, and later releases include CLR 4, so we can keep both .NET Framework 3.5 and .NET Framework 4/4.5(only one version) on the same computer, that why you can successfully install the .NET Framework 3.5. But due to the same CLR 4, we can only keep only one 4.x version on the same computer, then you cannot install the .Net framework 4.5 since you already have the higher version 4.7.

    BTW, why do you want to the .NET Framework 4.5? As far as I know, you should already have the .Net Framework 4.5 on your computer, if you have VS version like 2015/2017, you can try to create a new project and click drop down list for Framework, it should list the .Net Framework 4.5 as below:

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, April 3, 2018 8:33 AM
    Moderator
  • Hi SHAMIL T,

    What about this issue? Would you please share us the latest information in your side?

    Do you install the VS2017 in your machine?

    Like this screen shot:

    Visual Studio Installer with the .NET desktop development workload

    If you install the VS2017, you could install old .NET Framework versions.

    But if you don't install the VS, I mean that just install .NET 4.7, you cannot install an earlier version of the .NET Framework 4.x on a system  that already has a later version installed.

    We didn't get the response from, if you get any update, feel free to share it here.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 17, 2018 1:30 AM
    Moderator