none
Suggestions disappeared, help!

    Question

  • Hello,

    After some time development of my project suggestions disappeared. This phenomena exits only in lib project. In another solution's projects works fine. I have tried to restart VS, repair it, reset it also another google solutions, but no luck.

    Without suggestions is very difficult to develop.

    Monday, January 11, 2016 9:57 PM

All replies

  • Hi,

    According to your description, it seems that the intelligence of the visual studio does not work properly for you. I will help you move this issue to Visual Studio Forum for a better support.

    Thanks for your understanding.

    May


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, January 12, 2016 3:16 AM
  • Hi,

    Thanks for your post.

    Did you mean the intelliSense is unavailable?

    Could you please tell me what’s the version of your Visual Studio?

    And what’s your project type?

    Since it works fine in another solution’s project. I suppose there might be something wrong with the lib project.

    You may try the following steps and then try it again:

    1.Close the solution
    2.Make sure you can see hidden files
    3.Delete the suo file.
    4.Reopen solution.

    If still no help. Try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode)

    Also please try to install the latest update of Visual Studio and try it again.

    For example: If you were using VS2013. Install VS2013 update5 . If you were using VS2015. Install VS 2015 Update1.

    By the way. If you were using C++ projects. Please take a look at the following two links.

    You could refer to the following document about “When IntelliSense Is Unavailable”:

    https://msdn.microsoft.com/en-us/library/ks1ka3t6(v=vs.90).aspx

    This document is about “Troubleshooting IntelliSense in C++ Projects” for your reference:

    https://msdn.microsoft.com/en-us/library/ms235519(v=vs.90).aspx

    Hope that could be helpful to you.

    Best Regards,

    Lake Xiao
    Wednesday, January 13, 2016 6:48 AM
    Moderator
  • I'm using Visual Studio 2013 Pro. My project is static library. I have tried to delete sou file, re scan solution, close solution, reset visual studio, reinstall visual studio. Non helped. I guest that something is bad with my project. I will update you how update install went
    Wednesday, January 13, 2016 11:54 AM
  • Hi,

    Thanks for your quick response.

    Please try to test using a new static library. If the suggestion disappears only for your specified project.

    May be the problem is in your project. In this case. I suggest you could create a new empty solution and add a new static library. Then try you copy the code from your project to the new lib project then try it again.

    Best Regards,

    Lake Xiao

    Thursday, January 14, 2016 1:33 AM
    Moderator