none
Log Analytics Agent not installed on VM RRS feed

  • Question

  • Hi,

    I setup Security Center in Azure for one of my subscriptions. 

    I set Automatic Provisioning "On" and expect that every VM created under that subscription has Log Analytics Agent installed by default(that is what I understand from the documentation "Data Collection in Azure Security Center".

    However, the agent is not installed as expected when I create a new VM. I even see the message "All set! All of your Azure subscriptions have automatic agent installation enabled" What might be preventing new VMs from having the agent installed?

    Thanks,

    Canan

    Monday, November 11, 2019 10:46 PM

All replies

  • Ideally when automatic provisioning is On, Security center will provisions the log analytics agent on any new or existing VM's.  For VMs, you need to make sure that -

    • The Microsoft Monitoring Agent extension is not currently installed on the VM.
    • The VM is in running state.
    • The Windows or Linux Azure Virtual Machine Agent is installed.
    • The VM is not used as an appliance such as web application firewall or next generation firewall.

    Please let me know if you are still having this issue for any new VMs.

    Tuesday, November 12, 2019 5:59 PM
    Moderator
  • Hi Canan. Just checking to see if Saurabh's reply was helpful to you. If so, please remember to mark as answer so that others in the community with similar questions can more easily find a solution.

    Please take a moment to "Mark as Answer" and/or "Vote as Helpful" wherever applicable. Thanks!

    Tuesday, November 26, 2019 8:34 PM
    Moderator