locked
Windows Developer Preview : System time resets to -2 hours on every restart

    Question

  • Hi,

    I installed WDP 32 bit edition 2 days back. I found the details in cnet where the download link available. So, I downloaded it from http://msdn.microsoft.com/en-us/windows/apps/br229516 (Windows 8 Developer Preview English, 32-bit (x86))

    I am having a strange problem, that even though my time zones is correct, the time always shows two hours less.

    While installation, I was sleeping (??).  So, It automatically took US time. Then I changed my time zone to Hungary(Budapest, UTC+1 DayLightSaving). I am not sure whether it showed wrong time or not for the 1st time. But on every restart of my system, it shows -2 hours less than actual time, even though time zone is (UTC+01:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague

    I don't know whether its a bug or not. But to report , I don't find win8 or WDP here http://connect.microsoft.com/directory/

    I could not understand that If users don't have option to report bugs why is this edition released, (I am not sure, I didn't searched completely)

    Saturday, October 15, 2011 10:35 AM

Answers

  • If you are using a Mac that is a common problem that can be fixed with the following fix that implies editing a Registry Editor key, otherwise you could also try this fix:

    1. Open Regedit.exe
    2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
    3. Create (if it doesn't exist yet) a new DWORD key with the name RealTimeIsUniversal and the value of 1.
    4. Reboot.
    If everything went OK, from now on the date should be fixed.
    • Marked as answer by Aditya chs Sunday, October 16, 2011 1:18 PM
    Saturday, October 15, 2011 11:56 AM
  • Hi Roberto,

     

    Thanks for quick response. I am not using MAC, its a old HP notebook (NC6400). But surprisingly the problem is resolved now, when I turned on and off of the metro feature using

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
    "RPEnabled"=dword:00000000

    Now my system works fine without problem :).

     

     

    Sunday, October 16, 2011 1:18 PM

All replies

  • If you are using a Mac that is a common problem that can be fixed with the following fix that implies editing a Registry Editor key, otherwise you could also try this fix:

    1. Open Regedit.exe
    2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
    3. Create (if it doesn't exist yet) a new DWORD key with the name RealTimeIsUniversal and the value of 1.
    4. Reboot.
    If everything went OK, from now on the date should be fixed.
    • Marked as answer by Aditya chs Sunday, October 16, 2011 1:18 PM
    Saturday, October 15, 2011 11:56 AM
  • I installed the same WDP iso in a multi-boot scenario with XP and 7 on my machine, and had a similar problem. Although I don't think it was 2 hours on every restart, My system time settings changed several times over the first couple of days. What brought it to my attention was when my Mom asked me how I emailed her on October 2nd when the date was September 30. The windows clock was displaying the correct time, but it was changing my time zone setting. It was set for UTC-5 Eastern Time US and Canada when I installed. By the time I noticed, it was at UTC+12 Fiji, and the date was 3 days ahead. I looked at my emails from the last 2 days and found that it had happened in at least 6 different stages. Here's the funny thing. After opening the System Time properties applet and setting it correctly one time, this has not happened again.
    Saturday, October 15, 2011 6:23 PM
  • Hi Roberto,

     

    Thanks for quick response. I am not using MAC, its a old HP notebook (NC6400). But surprisingly the problem is resolved now, when I turned on and off of the metro feature using

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
    "RPEnabled"=dword:00000000

    Now my system works fine without problem :).

     

     

    Sunday, October 16, 2011 1:18 PM