none
Create Client Printer on Server 2008 using IPP port RRS feed

  • Question

  • I am trying to migrate a webserver from 2003 to 2008 and am running into problems installing internet printers.  Under 2003 these are IPP printers with ports labeled "Internet Port" in the form of http://{address}:631/ipp

    When trying to create these printers on my 2008 server the http://{address}:631/ipp will not resolve and create a port.  I either get a communication error or it seems the wizard creates a TCP/IP printer and communication does not work and printed output returns errors.

    Any solutions or different methods to install these printers?
    Friday, May 8, 2009 7:59 PM

All replies

  • I ran into the same issue and from the research I did, I think the fix is:

    Go to 'Server Manager' and 'Roles'.
    Under the 'Print Services' role, choose 'Add Role Services' and make sure 'Internet Printing' is installed.

    After that you should be able to create printers using a URL.

    The server I had was running Citrix XenApp and after I spent a long time getting it installed, updated, and configured I wasn't going to take a chance on the IPP website that is autocreated breaking my Citrix XenApp page. Maybe I'll try it on a spare VM sometime just to make sure it works before I try it in production.

    Hope that helps, good luck!

    D

    PS Here's one of the only links I found with some instructions
    http://www.brodin.it/jobb/printerlab%20handledning.pdf
    Monday, May 11, 2009 10:10 PM
  • I have the Internet Printing Client installed.  To clarify I'm not trying to host printers on the new 2008 server I'm trying to connect to printers over the internet with the supplied URL in the form of http://{address}:631/ipp  These printers have traffic routed through a router or firewall to some type of print server, often HP JetDirects. 

    I've been able to install the printer on a Vista workstation with the "Internet Port" as the port type but Server 2008 is giving me problems.
    Tuesday, May 12, 2009 8:56 PM
  • I have the Internet Printing Client installed.  To clarify I'm not trying to host printers on the new 2008 server I'm trying to connect to printers over the internet with the supplied URL in the form of http://{address}:631/ipp   These printers have traffic routed through a router or firewall to some type of print server, often HP JetDirects. 

    I've been able to install the printer on a Vista workstation with the "Internet Port" as the port type but Server 2008 is giving me problems.

    I have the same problem.

    Sylvain
    • Proposed as answer by F. Oshizzle Saturday, September 5, 2009 4:40 AM
    Friday, May 15, 2009 6:01 PM
    • How to Configuring IPP on Windows Server 2008

      what I'm going to suggest will remove any secure funtionality but it will work and from there, someone can add the secure funtionality back properly.

      1. Go to 'Server Manager' and 'Roles'.
      2. Under the 'Print Services' role, choose 'Add Role Services' and make sure 'Internet Printing' is installed.
      3. Assuming you have printers already installed on your Print Server, from a computer on your network, type in the address using the local machine name. Example: http://{servername}/printers. Your printers should be listed, even (shared) Faxes.
      4. Now this proves that the service is up and running
      5. From an external client computer, type in the URL, http://{000.000.000.000}/printers.  I had to use the IP instead of name, for some reason the name would not resolve properly...
      6. your printers will list but you wont be able to install the drive due to it failing because of not finding the printer name.
      7.
      I also noticed in the pdf link listed above there is no mention of having to log onto the site. You log in using the proper domain/username.
      8. Well the down and dirty solution i used was to disable windows authentication for the particular site - go into IIS 7.0 - Default Web Sites\Printers. highlight the "Printers" folder.
      9. double click the "Authentication" icon, and disable "Windows Authentication" and verify "Authorization Rules"  lists "Allow" and "All Users". This gets rid of the challenge box.
      10. Manually download the drivers onto the client and install the drivers via Print Server Properties (As Administrator)..
      11.
      Open IE go to Tools\Internet Options. select the Security Tab. slide the security level to medium. uncheck the "protected mode" box. click "ok". close and re-open browser.
      12. now go back to the printers website and select your printer. click "connect".

      this works for me so i can at least sample the tech!
      PS. there is an active x module that will prompt you for installation - please do install
    • Proposed as answer by thecleanupguy Friday, June 25, 2010 7:11 PM
    Saturday, September 5, 2009 5:34 AM
  • For windows server 2008. you need to enable IPP client under the server manager.. then you need to go to microsoft and request the hotfix here.

    http://support.microsoft.com/kb/982643/en-us

     

     

     

     

    • Proposed as answer by thecleanupguy Friday, June 25, 2010 7:14 PM
    Friday, June 25, 2010 7:14 PM
  • try this as well

     

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/f5e69f33-29ff-4c86-a7ed-3b066f0b642d

    Thursday, July 15, 2010 5:08 AM
  • 1.    Go to 'Server Manager' and 'Features'.

    2.    Add the ‘Internet Printing Client’ feature, required for connecting to network shared printers.

    3.    Go to ‘Start’ -> ‘Run’ -> ‘services.msc’ and restart the ‘Print Spooler’ service.

     

    After completion of this, go to ‘Start’ -> ‘Devices and Printers’ and add the required network printer using the wizard.

     

    However, if an attempt has been made to add a network printer without having performed the aforementioned steps, then this would have added a local printer of the same name onto the system. Subsequent attempts, even after having performed the aforementioned steps, result in addition of a local printer with the same name.

     

    To resolve this, the following steps need to be performed.

     

    1.    Go to 'Server Manager' and 'Roles'.

    2.    Under the 'Print and Document Services' role, make sure that ‘Print Server’ and 'Internet Printing' are selected when installing the role.

    3.    After installation, go to ‘Administrative Tools’ -> ‘Print Management’ and expand ‘Print Servers’.

    4.    Go to ‘Printers’ and delete the local printer which was installed when trying to add the network printer.

    5.    Go to ‘Drivers’ and delete the driver which was installed for the local printer.

    6.    Go to ‘Ports’ and delete the port which was associated for the local printer.

     

    After completion of this, go to ‘Start’ -> ‘Devices and Printers’ and add the required network printer using the wizard. The printer can be added utilizing the URL http://serverName/printers/printerName/.printer without the hassle of trying to add using TCP/IP.
    • Proposed as answer by degenerated Thursday, January 13, 2011 12:25 PM
    Thursday, January 13, 2011 12:25 PM