locked
WebDeploy ERROR_USER_NOT_ADMIN RRS feed

  • Question

  • User-1573578539 posted

    I tried web deploy on a remote machine, but hit "ERROR_USER_NOT_ADMIN". I can't use domain administrator account neither built-in administrator account. But i have create a user group "MSDepSvcUsers" and create new administrator account and added into the group. But yet still received same error.

    Please advice.

    Monday, August 14, 2017 9:49 AM

Answers

  • User1771544211 posted

    Hi kevinxox,

    Please try the following scenarios:

    1. Search mmc and run it click on File add or remove snap-ins, select Local Users and Groups hit ok. Click on the User uncheck everything and check only Password never expires. Go to Groups add new group if it does not exists MSDepSvcUsers, Double click on it and add your User as a member. Go to Services and restart the Web Deployment Agent Service. Now try and run your MSDeploy.

    2. Use Web Management Service (WMSVC) for remote deployment by non-administrators. The following link shows how to do this, please take it as reference.

    https://blogs.msdn.microsoft.com/amol/2011/02/09/allowing-non-admin-users-to-deploy-web-applications-on-iis-7-using-web-deploy-2-0/

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 15, 2017 2:10 AM

All replies

  • User1771544211 posted

    Hi kevinxox,

    Please try the following scenarios:

    1. Search mmc and run it click on File add or remove snap-ins, select Local Users and Groups hit ok. Click on the User uncheck everything and check only Password never expires. Go to Groups add new group if it does not exists MSDepSvcUsers, Double click on it and add your User as a member. Go to Services and restart the Web Deployment Agent Service. Now try and run your MSDeploy.

    2. Use Web Management Service (WMSVC) for remote deployment by non-administrators. The following link shows how to do this, please take it as reference.

    https://blogs.msdn.microsoft.com/amol/2011/02/09/allowing-non-admin-users-to-deploy-web-applications-on-iis-7-using-web-deploy-2-0/

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 15, 2017 2:10 AM
  • User-1573578539 posted

    Hi kevinxox,

    Please try the following scenarios:

    1. Search mmc and run it click on File add or remove snap-ins, select Local Users and Groups hit ok. Click on the User uncheck everything and check only Password never expires. Go to Groups add new group if it does not exists MSDepSvcUsers, Double click on it and add your User as a member. Go to Services and restart the Web Deployment Agent Service. Now try and run your MSDeploy.

    2. Use Web Management Service (WMSVC) for remote deployment by non-administrators. The following link shows how to do this, please take it as reference.

    https://blogs.msdn.microsoft.com/amol/2011/02/09/allowing-non-admin-users-to-deploy-web-applications-on-iis-7-using-web-deploy-2-0/

    Best Regards,

    Jean

    Thanks, Jean. It works now. Actually before this i have done option 1, but not working. May be it only take effect after restart the service.

    Tuesday, August 15, 2017 6:38 AM