locked
BizTalk admin console error Provider load failure RRS feed

  • Question

  • Hi,

    I am facing issue with BizTalk admin console, getting below error, 

    i  thought it will be due to sql server or WMI so restarted sql services as well WMIS services but no luck. restarted Distributed transaction services as well as restarted machine but it did not solve.

    TITLE: BizTalk Server Administration

    ------------------------------

    Failed to load Group [AMTROWBT13DV04\AMTROWBT13DEV:BizTalkMgmtDb] data providers. (Microsoft.BizTalk.Administration.SnapIn)

    For help, click: http://go.microsoft.com/fwlink/?LinkId=47400&ProdName=Microsoft+BizTalk+Server+2013+R2&ProdVer=3.11.158.0&EvtSrc=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors&EvtID=FailedLoadingGroupProviders&EvtChain=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors+%2cFailedLoadingGroupProviders

    ------------------------------
    ADDITIONAL INFORMATION:

    Failed to load Group [AMTROWBT13DV04\AMTROWBT13DEV:BizTalkMgmtDb] data providers. (Microsoft.BizTalk.Administration.SnapIn)

    For help, click: http://go.microsoft.com/fwlink/?LinkId=47400&ProdName=Microsoft+BizTalk+Server+2013+R2&ProdVer=3.11.158.0&EvtSrc=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors&EvtID=FailedLoadingGroupProviders

    ------------------------------

    Provider load failure  (System.Management)

    -------------------------------------------------------------------------------------------------

    after looking at event viewer i can see few more error messages, 

    Faulting application name: mmc.exe, version: 6.3.9600.16384, time stamp: 0x52158765
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.17055, time stamp: 0x532943a3
    Exception code: 0xe0434352
    Fault offset: 0x00011d4d
    Faulting process id: 0x215c
    Faulting application start time: 0x01d004a6e0c31506
    Faulting application path: C:\windows\SysWOW64\mmc.exe
    Faulting module path: C:\windows\SYSTEM32\KERNELBASE.dll
    Report Id: 3d994be7-709f-11e4-80ee-00505689506c
    Faulting package full name: 
    Faulting package-relative application ID:

    ***************************************************************************************

    Application: mmc.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Reflection.TargetInvocationException
    Stack:
       at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(System.Object, System.Threading.ThreadExceptionEventArgs)
       at System.Windows.Forms.Application+ThreadContext.OnThreadException(System.Exception)
       at System.Windows.Forms.Control.WndProcException(System.Exception)
       at System.Windows.Forms.Control+ControlNativeWindow.OnThreadException(System.Exception)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)
       at System.Windows.Forms.UnsafeNativeMethods.IntDestroyWindow(System.Runtime.InteropServices.HandleRef)
       at System.Windows.Forms.UnsafeNativeMethods.DestroyWindow(System.Runtime.InteropServices.HandleRef)
       at System.Windows.Forms.NativeWindow.DestroyHandle()
       at System.Windows.Forms.Control.DestroyHandle()
       at System.Windows.Forms.Control.Dispose(Boolean)
       at Microsoft.BizTalk.Administration.SnapIn.Forms.GroupHub.OperationsCtrl.Dispose(Boolean)
       at System.ComponentModel.Component.Dispose()
       at Microsoft.ManagementConsole.FormView.InternalShutdown()
       at Microsoft.ManagementConsole.View.HandleShutdownRequest(Microsoft.ManagementConsole.Internal.IRequestStatus)
       at Microsoft.ManagementConsole.View.ProcessRequest(Microsoft.ManagementConsole.Internal.Request)
       at Microsoft.ManagementConsole.ViewMessageClient.ProcessRequest(Microsoft.ManagementConsole.Internal.Request)
       at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Microsoft.ManagementConsole.Internal.Request)
       at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(Microsoft.ManagementConsole.Internal.IMessageClient, Microsoft.ManagementConsole.Internal.RequestInfo)
       at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
       at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(Microsoft.ManagementConsole.Executive.SimpleOperationCallback)
       at System.RuntimeMethodHandle.InvokeMethod(System.Object, System.Object[], System.Signature, Boolean)
       at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(System.Object, System.Object[], System.Object[])
       at System.Reflection.RuntimeMethodInfo.UnsafeInvoke(System.Object, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo)
       at System.Delegate.DynamicInvokeImpl(System.Object[])
       at Microsoft.ManagementConsole.Executive.DelegateMessage.OnExecute()
       at Microsoft.ManagementConsole.Executive.Message.Execute()
       at Microsoft.ManagementConsole.Executive.SnapInThread.DispatchPendingSnapInMessages()
       at Microsoft.ManagementConsole.Executive.SnapInThread.OnDataReadyAsync(System.Object, System.EventArgs)
       at Microsoft.ManagementConsole.Executive.MmcThreadMessageWindow.WndProc(System.Windows.Forms.Message ByRef)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)
       at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG ByRef)
       at System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32)
       at System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext)
       at System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext)
       at System.Windows.Forms.Application.Run()
       at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.Microsoft.ManagementConsole.Internal.ISnapInMessagePumpProxy.Run()
       at Microsoft.ManagementConsole.Internal.ISnapInMessagePumpProxy.Run()
       at Microsoft.ManagementConsole.Executive.SnapInThread.OnThreadStart()
       at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
       at System.Threading.ThreadHelper.ThreadStart()

    does any one face similar issue if yes can you please help me to solve this?

    Regards,

    Amit


    Regards, Amit More

    Thursday, November 20, 2014 11:55 AM

Answers

  • hi Paul,

    WMI service is running properly and i installed biztalk as per the document. 

    nothing has worked,  i have asked to rebuild my server.


    Regards, Amit More

    • Marked as answer by Amit C More Wednesday, November 26, 2014 7:59 AM
    Wednesday, November 26, 2014 7:59 AM

All replies

  • Do other MMC's work?  If not, the problem is with Windows.

    If they do, first, try a Repair of the BizTalk install from Add/Remove Programs.

    Thursday, November 20, 2014 12:16 PM
    Moderator
  • Repair your BizTalk Installation  from Control panel Add Remove Program . you are getting "C:\windows\SYSTEM32\KERNELBASE.dll"  exception and it is generally caused due  to setup being corrupted .

    Thanks

    Abhishek

    • Marked as answer by Angie Xu Wednesday, November 26, 2014 1:38 AM
    • Unmarked as answer by Amit C More Wednesday, November 26, 2014 7:57 AM
    Thursday, November 20, 2014 12:46 PM
  • i tried with other MMC's and i don't find any issue, i mean i am able to do task on mmc's.

    Regards, Amit More

    Thursday, November 20, 2014 1:11 PM
  • is it possible to repair the installation, i never did so asking. 

    Regards, Amit More

    Thursday, November 20, 2014 1:15 PM
  • try a Repair of the BizTalk install from Add/Remove Programs.

    Yes, you can Repair.
    Thursday, November 20, 2014 1:41 PM
    Moderator
  • is it possible to repair the installation, i never did so asking. 

    Regards, Amit More


    No issues you can go ahead with BizTalk repair . Just one consideration you need to have BizTalk setup with you just in case if repair ask for the Biztalk setup
    Thursday, November 20, 2014 3:00 PM
  • If it is a temporarily issue, you have to check a network of SQL. In my experience it happens if SQL is really busy or if network slows down. SQL is busy if there are many many Admin sessions are opened or big queries are performed or if MessageBox is under a high load.

    Leonid Ganeline [BizTalk MVP]

    Thursday, November 20, 2014 8:31 PM
    Moderator
  • Hi Amit,

    Before performing repair have a look at the below blog may be it can help.

    biztalk-server-admin-console-fails-to-launch


    Thanks,
    Prashant
    ----------------------------------------
    Please mark this post accordingly if it answers your query or is helpful.

    Friday, November 21, 2014 5:33 AM
  • Hi,

    regarding your initial Event viewer message the given exception actually says that mmc cannot load the PlugIn for BizTalk Server Management Console.

    There could be various reasons for this behaviour. The following steps should be considered:

    1. Check the paths mentioned in the exception message as well as BizTalk Installation paths in the Windows environment variable <Path>. If not appropriate set them accordingly and reboot the system.

    2. Check the BizTalk Management Console PlugIn Cache file <BTSmmc> in the folder <C:\Users\%username%\AppData\Roaming\Microsoft\MMC>. Delete it and try to load the  BizTalk Management Console PlugIn in mmc again.

    Actually, i could reproduce your Event viewer message with exactly the same execption, given the mmc a corrupt BTSmmc Cache file. 

    hth

    Paul Endras
    Endras IT Consulting | www.endras.de

    If this answers your question and is a helpful post, please click Vote As Helpful, Propose As Answer, and/orMark As Answer.



    • Edited by Paul Endras Friday, November 21, 2014 11:08 AM
    Friday, November 21, 2014 10:36 AM
  • thanks Paul,

    Repair did not solve my problem .... your solution will try tomorrow morning first activity.


    Regards, Amit More

    Sunday, November 23, 2014 6:33 AM
  • Hi Paul,

    I did as you said, checked the Path environment variable and it seems good. also deleted the BTSmmc file from specified location but it did not help, getting same error message "Provider load failure".

    so finally i decided to uninstall and install the BizTalk server, I install BizTalk server but while configuring Group again it is failing with same error message "Provider load failure".

    not sure what is wrong now. 

    Regards,

    Amit


    Regards, Amit More

    Monday, November 24, 2014 8:10 AM
  • Are you working with clustered SQL node ? Can you check if MSTDC is working between your Application and BizTalk DB server
    Monday, November 24, 2014 9:04 AM
  • SQL is not clustered, its my local development box.

    Regards, Amit More

    Monday, November 24, 2014 9:43 AM
  • here is log generated during configuration,

    [2014-11-24 05:16:10:0572 Info Configuration Framework]Configuring feature: WMI
    [2014-11-24 05:16:10:0588  Info BtsCfg] Entering function: CBtsCfg::ConfigureFeature
    [2014-11-24 05:16:10:0588  Info BtsCfg] Configuring feature: WMI
    [2014-11-24 05:16:10:0588  Info BtsCfg] Entering function: CBtsCfg::IsSelectedAnswer
    [2014-11-24 05:16:10:0588  Info BtsCfg] Leaving function: CBtsCfg::IsSelectedAnswer
    [2014-11-24 05:16:10:0588  Info BtsCfg] Entering function: CWMI::Connect
    [2014-11-24 05:16:10:0588  Info BtsCfg] Leaving function: CWMI::Connect
    [2014-11-24 05:16:10:0603  Info BtsCfg] Entering function: CWMI::CreateGroup
    [2014-11-24 05:16:10:0791  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btswmi.cpp(438): FAILED hr = 80041013

    [2014-11-24 05:16:10:0791  Error BtsCfg] Provider load failure

    [2014-11-24 05:16:10:0791  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btscfg.cpp(1801): FAILED hr = 80041013

    [2014-11-24 05:16:10:0791  Info BtsCfg] Entering function: CBtsCfg::UnConfigureFeature
    [2014-11-24 05:16:10:0791  Info BtsCfg] Unconfiguring feature: WMI
    [2014-11-24 05:16:10:0791  Warning BtsCfg] BTS management server or DB names are not found in the registry.
    [2014-11-24 05:16:10:0791  Info BtsCfg] Entering function: CWMI::StopHostInstance
    [2014-11-24 05:16:10:0807  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btswmi.cpp(1553): FAILED hr = 80041013

    [2014-11-24 05:16:10:0807  Error BtsCfg] Provider load failure

    [2014-11-24 05:16:10:0807  Info BtsCfg] Entering function: CWMI::UnMapHost
    [2014-11-24 05:16:10:0807  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btswmi.cpp(1698): FAILED hr = 80041013

    [2014-11-24 05:16:10:0807  Error BtsCfg] Provider load failure

    [2014-11-24 05:16:10:0807  Info BtsCfg] Instantiating IBTSMsgBoxPerformance object
    [2014-11-24 05:16:10:0869  Info BtsCfg] Calling IBTSMsgBoxPerformance::UninstallArtifacts
    Exception in CounterManager.UninstallArtifacts when uninstalling the perf counter instances. The exception details are: 
    Source of exception: System
    Message: Cannot delete Performance Category because this category is not registered or is a system category.
    Stack trace:    at System.Diagnostics.PerformanceCounterCategory.Delete(String categoryName)
       at Microsoft.BizTalk.MsgBoxPerfCounters.MgmtDbAccessEntity.UninstallInstances(Boolean regularUninstall)
       at Microsoft.BizTalk.MsgBoxPerfCounters.CounterManager.UninstallArtifacts(Boolean regularUninstall, String logFileName)
    [2014-11-24 05:16:11:0166  Info BtsCfg] Stopping Tracing
    [2014-11-24 05:16:11:0166  Info BtsCfg] Entering function: CWMI::DeleteServer
    [2014-11-24 05:16:11:0182  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btswmi.cpp(1353): FAILED hr = 80041013

    [2014-11-24 05:16:11:0197  Error BtsCfg] Provider load failure

    [2014-11-24 05:16:11:0197  Info BtsCfg] Entering function: CWMI::UnConfigureGroup
    [2014-11-24 05:16:11:0197  Error BtsCfg] d:\bt\127854\private\source\setup\btscfg\btswmi.cpp(1076): FAILED hr = 80041013

    [2014-11-24 05:16:11:0197  Error BtsCfg] Provider load failure

    [2014-11-24 05:16:11:0197  Info BtsCfg] Leaving function: CBtsCfg::UnConfigureFeature
    [2014-11-24 05:16:11:0197  Info BtsCfg] Leaving function: CBtsCfg::ConfigureFeature
    [2014-11-24 05:16:11:0213 Warning Configuration Framework]Feature failed to configure: WMI.
    [2014-11-24 05:16:11:0400 Info Configuration Framework]Configuration Summaries:
    [2014-11-24 05:16:11:0400 Error Configuration Framework]Feature: [Group] Failed to configure with error message [Provider load failure
    ]
    [2014-11-24 05:16:11:0400 Error Configuration Framework]Feature: [BizTalk Runtime] Failed to configure with error message [Feature is skipped due to dependent feature (Group) failed to configure correctly.]
    [2014-11-24 05:16:11:0400 Error Configuration Framework]Feature: [BAM Tools] Failed to configure with error message [Feature is skipped due to dependent feature (Group) failed to configure correctly.]
    [2014-11-24 05:16:11:0400 Error Configuration Framework]Feature: [BAM Portal] Failed to configure with error message [Feature is skipped due to dependent feature (Group) failed to configure correctly.]
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: SSOServer,Engine Configuration Enabled: yes Sub UI: no Configured: yes
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: SSOServer,Engine Configuration Enabled: no Sub UI: yes Configured: yes
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: WMI Configuration Enabled: yes Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: Engine,BTSCfg Configuration Enabled: no Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: RulesEngine Configuration Enabled: yes Sub UI: no Configured: yes
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: MOT Configuration Enabled: yes Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: BAMTools Configuration Enabled: no Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: BAMTools Configuration Enabled: no Sub UI: yes Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: BAMPortal Configuration Enabled: no Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework] Feature: MsEDIAS2 Configuration Enabled: no Sub UI: no Configured: no
    [2014-11-24 05:16:11:0400 Info Configuration Framework]Leaving function ConfigureFeatures().
    [2014-11-24 05:16:11:0416 Info Configuration Framework]Entering function WizardStep_NextStepChanged.
    [2014-11-24 05:16:11:0416 Info Configuration Framework]Entering function ConfigWizardResult_Load.
    [2014-11-24 05:16:11:0447 Info Configuration Framework]Leaving function ConfigWizardResult_Load.
    [2014-11-24 05:16:11:0478 Info Configuration Framework]Leaving function WizardStep_NextStepChanged.
    [2014-11-24 05:16:14:0416 Info Configuration Framework]Displaying information notification to user. Message: <Exception Message="Provider load failure
    " Source="" HelpID="" />


    Regards, Amit More

    Monday, November 24, 2014 10:19 AM
  • Hi,

    pls check WMI service is up and running. Without WMI service you cannot access the BTS Group.

    Check again the preliminaries for the installation and configuration procedure found here:

    Installation Overview for BizTalk Server 2013 and 2013 R2

    hth

    Paul Endras
    Endras IT Consulting | www.endras.de

    If this answers your question and is a helpful post, please click Vote As Helpful, Propose As Answer, and/orMark As Answer.

    • Marked as answer by Angie Xu Wednesday, November 26, 2014 1:37 AM
    • Unmarked as answer by Amit C More Wednesday, November 26, 2014 7:57 AM
    Monday, November 24, 2014 2:39 PM
  • hi Paul,

    WMI service is running properly and i installed biztalk as per the document. 

    nothing has worked,  i have asked to rebuild my server.


    Regards, Amit More

    • Marked as answer by Amit C More Wednesday, November 26, 2014 7:59 AM
    Wednesday, November 26, 2014 7:59 AM
  • That is common problem with BizTalk environments after operating system has been patched WMI is corrupted.

    To resolved that problem you need to look for instructions how to re-install WMI on OS

    Wednesday, November 26, 2014 1:43 PM
  • Hi Amit,

    If you are still facing issue then I would suggest you to open a ticket with Microsoft, they should be able to help you with it.


    Thanks,
    Prashant
    ----------------------------------------
    Please mark this post accordingly if it answers your query or is helpful.

    Thursday, November 27, 2014 12:23 AM
  • Thanks for info

    Regards

    Enis,

    Sunday, November 30, 2014 3:12 PM