none
framework 4 and framework 2 RRS feed

  • Question

  • I have Windows 7, and I have .net framework 4 installed, but I keep getting the message that I need to install .net framework 2.
    Sunday, January 1, 2012 8:24 PM

Answers

  • The following .NET Frameworks are installed with Windows 7 as part of the OS:

    .NET Framework 2.0, 3.0 and 3.5 with all updates through 3.5 SP1.

    So, you already have 2.0. You CANNOT install it.

    FWIW, 3.0 and 3.5 are not separate frameworks. They are extensions to 2.0. So, .NET Framework 2.0/3.0/3.5 is a single framework.

    If you look in Control Panel->Programs and Features->Turn Windows fratures on and off...

    you will find Microsoft .NET Framework 3.5.1 as an entry in the Windows Features dialog. This is 2.0/3.0/3.5 through 3.5 SP1.

    Click the + next to the Microsoft .NET Framework 3.5.1 entry and put checks in all the subfeatures to full activate the framework.

    You can also verify your .NET Frameworks with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first 20 lines and last 20 lines of tool output back here.

    If you continue to get the message you cited, you have software installed that is either for an older Windows version, or is defective. Please indicate what program is sending the message.

     


    Sunday, January 1, 2012 10:52 PM