none
Problem with black lines in watch window

    Question

  • In VS2012, using the Light color theme, when I set a watch on a variable the whole watch line turns black. Can't seem to find anything that will fix this.

    I'm using version: 11.0.50727.1

    Any ideas?

    Thanks,

    Rut


    Mike Rutledge

    Tuesday, October 30, 2012 12:23 PM

Answers

  • Hi Mike.

    Just find out, this is a known issue that has been fixed. Review this connect report. It will be in next Visual Studio quarterly update.

    Workaround:

    1. Go to VS Options > Font and Colors >
    2. Show Settings for "Watch Windows" >
    3. For Text Display item, select Automatic for Item Foreground.


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Proposed as answer by Forrest GuoModerator Monday, November 5, 2012 3:51 AM
    • Marked as answer by jmrut Monday, November 5, 2012 1:21 PM
    Monday, November 5, 2012 3:51 AM
    Moderator

All replies

  • Hi Rut,

    Do you mean you expect only one line turns black but the whole watch windows turns black?

    Could you please share a sceenshot for me to reproduce your error?

    Actually, if you add a new watch, it seems this is a feature that the line will turns black.

    BTW, what's your project type and language. Your issue seems more related to IDE usage issue. This is out of scope of this forum.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    Wednesday, October 31, 2012 5:59 AM
    Moderator
  • This is what I see. Each line where there is a variable to watch, the whole line turns black.

    Only when you click on that line can you tell what is in it.

    This is a vb.net windows app. Wasn't sure which forum this fits in.


    Mike Rutledge


    • Edited by jmrut Wednesday, October 31, 2012 11:39 AM
    Wednesday, October 31, 2012 11:38 AM
  • Hi jmrut,

    It seems the error may due to Graphic Driver.

    Could you please refer to this thread:

    http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/94ca2216-d5c0-41cf-bd67-30cfe6871732/

    Update your driver as described here: http://support.microsoft.com/kb/963021

    Will your issue solved?

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, November 1, 2012 8:42 AM
    Moderator
  • Thanks for the info. Unfortunately it did not resolve the problem. I updated to the latest Nvidia drivers but still see this issue. FYI, I don't have this problem in VS2005 or VS2008 (both installed on this machine).

    Rut


    Mike Rutledge

    Thursday, November 1, 2012 12:21 PM
  • Hi Rut,

    Thanks for this feedback.

    I'm trying to involve some experts here.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, November 2, 2012 7:24 AM
    Moderator
  • Does this issue occurs at the beginning you use VS 2012, or a period of time later? I'd like to know if other software introduces the problem.

    • Run command line as elevated: devenv /setup

    this will merge resource metadata

    • Launch VS in safe mode, this can tell us if any addin introduces the problem.  devenv /safemode

    thanks & regards,


    Forrest Guo | MSDN Community Support | Feedback to manager

    Friday, November 2, 2012 11:22 AM
    Moderator
  • Ok. ran setup and vs in safe mode. Still have the same results. This happens from startup. Also, to be clear, this is the professional version dated 8/15 downloaded from msdn. Would that make a difference? Are these the most recent versions?


    Mike Rutledge

    Friday, November 2, 2012 12:12 PM
  • Hi Mike.

    Just find out, this is a known issue that has been fixed. Review this connect report. It will be in next Visual Studio quarterly update.

    Workaround:

    1. Go to VS Options > Font and Colors >
    2. Show Settings for "Watch Windows" >
    3. For Text Display item, select Automatic for Item Foreground.


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Proposed as answer by Forrest GuoModerator Monday, November 5, 2012 3:51 AM
    • Marked as answer by jmrut Monday, November 5, 2012 1:21 PM
    Monday, November 5, 2012 3:51 AM
    Moderator
  • Thanks. This took care of the problem.

    Mike Rutledge

    Monday, November 5, 2012 1:21 PM