none
CAN NOT INSTALL NET.Framework 4.0 PLEASE HELP!!! (I've tried everything) RRS feed

  • Question

  • Hi

    I REALLY need help installing NET.Framework on my computer! This is when the Problem started:

    I already had microsoft NET.Framework installed on my computer, however every time I would launch the game 'Terraria' through steam, it would prompt me to install NET. Framework again! So I looked it up online and decided I would uninstall all the versions of NET. Framework on my computer (of which there was an old version, and version 4.0) and then re-install it, to fix the problem. HOWEVER, when I went to re-install it (NET.Framework), it failed with the error code: (0x00000BC9), and told me to reboot my system to roll back changes made. So I restarted my computer and tried again, and it failed with the same message and error code. So next I used the clean-up tool for NET.Framework, followed the instructions it gave me and tried again, and of-course it failed again, then told me the tool was unable to resolve the issue and it had sent the log files to microsoft for analysis (no help whatsoever).

    I have searched the web for help numerous times, but found nothing other than more people saying to reboot my system (exactly what the install window says). And I have shut-down/Restarted my computer numerous times, with no impact made.

    Here are my computer's OS details:

    -Windows 7 64-bit (Home Premium)

    -Service Pack 1

    And here is the full Installation log for NET.Framework 4.0:

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\6c2e5283a3514c868b8b8e151f\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = GMT Daylight Time
    Initial LCID = 2057
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 11

    Final Result: Installation failed with error code: (0x00000BC9), "The requested operation failed. A system reboot is required to roll back changes made. " (Elapsed time: 0 00:01:34).

    PLEASE HELP!!!

    Thanks

    Friday, August 2, 2013 5:12 PM

Answers

All replies

  • Please try this procedure:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Saturday, August 3, 2013 2:26 PM
  • Hi, Thanks for the reply

    I've tried what you said twice, and followed the steps exactly. However it has failed again with the same message. I followed the steps for collecting my logs, and have uploaded it to SkyDrive.

    Ok I just tried posting the link, but apparently I need my account verified. Can you verify it, or tell me how to get it verified please?

    Thanks

    Wednesday, August 7, 2013 6:44 PM
  • Hi Michael.C.94

    You don't need verify your accout to post link here. You need use button "Remove hyperlink" on your link.

    Best Regards.


    Samson sun
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 9, 2013 8:20 AM
  • Ok thanks, can't beleive i didn't think of that haha.
    Friday, August 9, 2013 9:15 PM
  • Ok here is the link to my vslogs on skydrive: 

    https://skydrive.live.com/#cid=2238897DC4F8454B&id=2238897DC4F8454B%21105

    Thanks

    Friday, August 9, 2013 9:18 PM
  • For some reason, the .NET 4.0 install log is not included in your vslogs.

    Please check for this file on your system:

    C:\Users\Michael94\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20130807_191736818.html

    If you find it, please upload to your SkyDrive and post the link here.

    If you don't find it, please repeat the steps previously provided, and run Collect.exe immediately after the install fails. Upload the new vslogs.cab and post the link here.

    Saturday, August 10, 2013 2:26 PM
  • I found it, I've uploaded it to skydrive

    https://skydrive.live.com/#cid=2238897DC4F8454B&id=2238897DC4F8454B%21105

    Sunday, August 11, 2013 2:30 AM
  • Monday, August 12, 2013 2:00 PM