locked
Tumbling Window Parameters RRS feed

  • Question

  • Hi,

    Right when I think I have everything working, I realize that my Tumbling Window is not working once I added the Parameters to the JSON. Please help; I have worked on this alot of today. My Tumbling Window JSON is as follows: Then please see the screen shot and you can see it does not have a Tumbling Window Event icon with it and the Tumbling Window is not Tumbling. Please help...Thanks!!!! Mike



    Mike Kiser

    Wednesday, November 27, 2019 3:46 AM

Answers

  • Looks like same pipeline is referred twice in the code. Try removing the part which is duplicate (outside the square brackets).

    Also would suggest, open a pipeline and add a trigger from there following wizard instead of editing json. 


    If the response helped, do "Mark as answer" or upvote it
    - Vaibhav

    Wednesday, November 27, 2019 5:56 AM
  • How do you enter parameters with the UI? 

    You may check the below steps and see if the created trigger works. 


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    • Marked as answer by EMKISER Friday, November 29, 2019 10:52 PM
    Thursday, November 28, 2019 5:42 AM

All replies

  • Looks like same pipeline is referred twice in the code. Try removing the part which is duplicate (outside the square brackets).

    Also would suggest, open a pipeline and add a trigger from there following wizard instead of editing json. 


    If the response helped, do "Mark as answer" or upvote it
    - Vaibhav

    Wednesday, November 27, 2019 5:56 AM
  • Thanks, Vaibhav,

    I can't believe I did that lol; thanks so much. I was up very late working on it and kept looking at the JSON and didn't notice the duplicate. How do you enter parameters with the UI? 

    Thanks!
    Mike Kiser


    Mike Kiser

    Wednesday, November 27, 2019 3:56 PM
  • How do you enter parameters with the UI? 

    You may check the below steps and see if the created trigger works. 


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    • Marked as answer by EMKISER Friday, November 29, 2019 10:52 PM
    Thursday, November 28, 2019 5:42 AM
  • Ah, I see now. Only one more question...how do I associate a Tumbling Window Trigger with only a particular Blob Folder? I don't see where to tell it to Tumble in a Particular folder such as the following folder:

    8/ConfigSettingMetric/

    Thanks!
    Mike


    Mike Kiser

    Friday, November 29, 2019 10:54 PM