locked
Crystal Reports plugin on IIS RRS feed

  • Question

  • User2103817411 posted

    Hey guys,

    I need some help regarding an application I currently work on. I use Visual Studio 2010 and .NET 4.0 as an IDE and the Crystal plugin for VS2010. The project works just fine, as long as I run it on my local machine. However, if I deplay it to our local web server I always get a fault exception: "Cannot create ActiveX component."

     I read various search hits on Google, but didn't find anything helpful. It seems, that it's some rights management problem, but I don't have any idea how I could solve this problem. I already changed the pool identity to LocalSystem, which didn't had any effect.

    My application is written in VB.NET and everything works just fine on my local development machine. The IIS is running on a separate Win Server 2008 R2, registered to our domain. I cannot get any further error codes or anything else helpful.

    The only thing some people suggested was to enable the IIS to use the COM+ or ActiveX component. I thought, this is enabled by default. If not, could you please tell me where I can activate it?

    Thank you!

    Andre

    Thursday, October 20, 2011 10:55 AM

All replies

  • User-1672167363 posted

    Hi,

    Have you installed the Crystal Reports runtimes on the Windows 2008 server ?

     http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/22083%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A+CystlR+%2528SAP+Weblogs%253A+Crystal+Reports%2529 .

    Have you checked the Crystal Reports Forums http://forums.sdn.sap.com/thread.jspa?threadID=2062574&tstart=0 ?

    Martin

     

    Thursday, October 20, 2011 12:14 PM
  • User2103817411 posted

    Hey Martin,

    I have installed the "SAP Crystal Reports runtime engine for .NET Framework 4" from here, the 32 as well as the 64 bit version. Could that be the problem?

    I haven't checked out the SAP forums yet, so I will do that now. If I'll find the solution there, I will post it here.

    Thank you!

    Andre

    Friday, October 21, 2011 2:12 AM
  • User-1672167363 posted

    Hi Andre,

    Yes, Do read the Crystal Reports forums suggestions it will save time of trial & error.

    The Developer Guides for SAP / Crystal Reports Forms API downloads are also a source of help.    

    Since your Developing on Crystal Reports in IIS Server spend some time reading IIS Library guides for Accounts & Users

     http://learn.iis.net/page.aspx/140/understanding-built-in-user-and-group-accounts-in-iis-7-and-above/  Application Pools

    http://learn.iis.net/page.aspx/624/application-pool-identities/ to start with.

    Personal Comment:

    I find that Drawing Diagrams for the Workflow using logic shapes saves time while you go through the details to make things less confusing.:D.

    Feel free to post detailed errors for IIS Server issues.

    Fixing code errors and issues is more for the ASP.NET Web Site.

    Martin

     

     

     

     

    Friday, October 21, 2011 2:34 AM
  • User2103817411 posted

     Hm,

    I just realized, that the error appears far before the Crystal plugin is gettin loaded. It seems to be a general problem of external calls. I try to use the WMI before printing in order to check, if the printer is already set up correctly, and, if yes, if it's turned on. Even that doesn't work. This brought me to the conclusion, that there must be some rights problem which prevents the IIS from loading any tipe of ActiveX script.

    Here is the related code line, where I try to load the ActiveX:

        Private Function CheckPrinter() As ServiceStatusCode
            'Check printer via WMI
            Dim WMI = GetObject("winmgmts:{impersonationLevel=impersonate}!\\" & Target & "\root\cimv2")
            Dim Printer = WMI.ExecQuery("SELECT WorkOffline FROM Win32_Printer WHERE Name = ""Compa II 104/8""")
            'Process data
            If Printer.Count <> 1 Then
                Return ServiceStatusCode.PrinterNotFound
            Else
                For Each Item In Printer
                    If Item.WorkOffline Then Return ServiceStatusCode.PrinterNotAvailable
                Next
            End If
            Return ServiceStatusCode.PrinterOK
        End Function

    Do you have any idea why this happens?

    Andre

    Wednesday, October 26, 2011 2:09 AM
  • User-1672167363 posted

    Hi,

    Look at the Default IIS 6.0 permissions http://support.microsoft.com/kb/812614 Microsoft Information.

    Also add the ASP.NET Account since your developing code against the IIS Server.

    Yes, The Cim Studio and WMI helps for Trouble Shooting :).

    Check the Accounts and Users who have permissions to control

    printers and devices and Active X controls.

    Use the Administrative Tools Managment then open Componet Services and Permissions section

    and check the Users Accounts for Launch and Activation.

    You might find the OleViewer will help http://social.msdn.microsoft.com/Forums/en/vcgeneral/thread/fa2bbdd1-4836-485d-a985-d54d4464019b .

    If you Search ( Google or Bing) OleViewer you may find this page http://www.mdgx.com/add.htm#MSE download

                            the installer and the "IVIEWERS.DLL".

    Martin

     

     

     

     

    Wednesday, October 26, 2011 2:26 AM
  • User2103817411 posted

    Thank you,

    But is there some quick start guide on how to set up the account permissions correctly? I never did that before, so I don't really know where to start.

     Andre

    Wednesday, October 26, 2011 6:22 AM
  • User-1672167363 posted

    Hi,

    I did a Search ( Goggle) for You Tube and IIS Server Permissions and the results are:

     http://www.google.com/search?q=you+tube+iis+server+permissions&rls=com.microsoft:en-us&ie=UTF-8&oe=UTF-8&startIndex=&startPage=1&rlz=1I7GUEA_en#hl=en&rls=com.microsoft:en-us&rlz=1I7GUEA_en&sa=X&ei=2t-nTumcC4GXtwfxkuz4Dw&ved=0CBcQBSgA&q=youtube+iis+server+permissions&spell=1&bav=on.2,or.r_gc.r_pw.,cf.osb&fp=eaa01c5641b8aa67&biw=1584&bih=610 

    I hope at least one of the Videos and Guides help.

    Be sure to Book Mark the Video or information since Google Search results change.

    Martin

     

    Wednesday, October 26, 2011 6:28 AM
  • User2103817411 posted

    Hm,

    I tried around a little, but it doesn't change anything. Still the same problem. I'm using annonymous authentification on the IIS, but switching it to Windows authentification results in a full screen error dialog with a lot of useless HTML content. I thought, this could be the problem, but nope, cannot change it. I have alsp played with the application pool settings, but any of the four standard users result in the same error message. Selecting a domain account manually fails, too.

    Do you have an idea how I could solve this mess? That would be so kind of you.

    Andre

    Wednesday, October 26, 2011 9:22 AM
  • User-1672167363 posted

    Hi,

    So you have "Anonoymous" on IIS Server then switch to "Windows Authentication"

    you get Full Screen error and "HTML Content" so what is the errors from the IIS Server log ?

    You made changes for Permissions and settings was the IIS Server or Windows 2008 Server restarted ?

    Maybe this http://support.microsoft.com/kb/264921 for IIS authentication

            and IE Browser http://support.microsoft.com/kb/258063 for Adding IE to the Trusted Zones might work.

    You can Search ( Google or Bing)  for the "Double Hope Issue" a being a common problem for Windows Servers and 2008.

    So is there Formal Written Project SRS Plan for how to do the Development with Testing then Deployment ?

    It seems as though your doing a lot of extra work. 

    Edit: Normally a planned Deployment should take maybe an hour.

    Martin

     

     

     

     

     

     

    You could look at this http://forums.iis.net/t/1182185.aspx  thread.

    Wednesday, October 26, 2011 9:42 AM
  • User2103817411 posted

    Hello,

    I switched to Windows authentification again and solved another problem. So here is the current error message (the error log is empty). The error appears while updating the service.

     I also get this inline exception, as soon as I click ok (it's in German, loosley translation afrerwards):

    Die HTTP-Anforderung ist beim Clientauthentifizierungsschema "Anonymous" nicht autorisiert. Vom Server wurde der Authentifizierungsheader "Negotiate,NTLM" empfangen.

    The HTTP call is not authorized at the client authentification scheme "Anonymous". The authentification header "Negotiate,NTLM" has been received.

    Any idea how I can solve this?

    Andre

    Wednesday, October 26, 2011 10:13 AM
  • User-1672167363 posted

    Hi,

    It appears Windows Server is using different regional language settings.

    If the IIS Server log is empty and your getting errors updating the Service you have permissions problems.

    You should check with the "System Administrator" or find an "Administrator" to deal with Logon User settings and permissions.

    Trial and error  for "Negotiate,NTLM"  at the Windows Server and Settings can lead to problems.

    If your  making "System Administrative" changes to get the Web Site and Application on the Server you may be

               causing problems for other Web Sites and Applications.

    Edit: This is no longer just "Crystal Reports plugin on IIS" and Web Server Deployment.

    Martin

     

     

     

    Wednesday, October 26, 2011 10:41 AM
  • User2103817411 posted

    Hi,

    Both, the server as well as the client, are running a German version of Windows. The main problem is, that I am one of the administrators in our company. Do you have any idea what I should change in order to get it running?

    Andre

    Wednesday, October 26, 2011 10:54 AM
  • User-1672167363 posted

    Hi,

     Your one of two Company Administrators for the Server contact the other Administrator use the IIS Resouce

          guide http://www.microsoft.com/download/en/details.aspx?id=5135 

    http://blogs.iis.net/nitashav/archive/2010/02/15/iis6-0-ui-vs-iis7-x-ui-series-anonymous-authentication.aspx

    http://blogs.iis.net/nitashav/archive/2010/03/12/iis6-0-ui-vs-iis7-x-ui-series-integrated-windows-authentication.aspx

      decide what are the correct settings make the changes to get it running in IIS Server.

    Martin

     

     

     

    Wednesday, October 26, 2011 11:31 AM