locked
Unable to Install VS Express 2012 for Windows 8 Because of .Net Version

    Question

  • I have been using Visual Studio Express 2012 for Windows 8 on my Windows 8 PC for months.  For some reason, it is now not letting me run the program. It gives me this error:

    The .Net Framework installed on this machine does not meet the minimum required version: 4.5.50709.

    I cannot install a more recent version of .Net because it tells me "Microsoft .NET Framework 4.5 is already a part of this operating system.  You do not need to install the .NET Framework 4.5 redistributable."

    I already re-installed Windows 8 and the same things are happening. My Windows 8 Build is 8400.  My .Net version is 4.5.50501 according to my registry.

    Does anybody know how I can fix this problem?

    Thanks,

    Jonn

    Tuesday, September 18, 2012 10:40 PM

Answers

  • It looks like you are trying to install the RTM version of VS Express 2012 for Windows 8 on a non-RTM version of Windows 8. The versions have to match, VS RTM can only work with Windows 8 RTM. 
    Wednesday, September 19, 2012 2:03 PM

All replies

  • It looks like you are trying to install the RTM version of VS Express 2012 for Windows 8 on a non-RTM version of Windows 8. The versions have to match, VS RTM can only work with Windows 8 RTM. 
    Wednesday, September 19, 2012 2:03 PM
  • Thanks for the response, Chuck.  I'll download the Windows 8 RTM Preview.

    Wednesday, September 19, 2012 4:12 PM