none
BizTalk 2013 and Cerberus Pro FTP RRS feed

  • Question

  • I am trying to connect a SFTP receive location to a Cerberus FTP server located in our DMZ.

    I am able to successfully authenticate and connect to the server but it seems BizTalk almost immediately sends an EOF bit, the server responds and shuts down the channel and as a result the receive location shuts down. 

    I have tried using just a username/pw combination as well as a published key, both produce the same result.

    This is the FTP Log:

    Has anyone seen this odd behavior with the SFTP adapter. I've read a few posts on other forums that this is an issue with the adapter and Cerberus. 

    We are trying to avoid using FTP or network share since this server is located in the DMZ.

    Tuesday, July 1, 2014 2:35 PM

Answers

All replies

  • HI Philip.

    I was able to get Cerberus to work.

    I was able to duplicate your problem, the issue seems to be the folder path on the receive adapter.

    I set up a user and put the files in the root dir of that user, then used ./ as the folder path in the receive adapter.

    Let me know if this works.

    Chas Hyman


    • Edited by chyman Tuesday, July 1, 2014 3:23 PM
    Tuesday, July 1, 2014 3:21 PM
  • I changed the path to "./" and the same error resulted.

    

    The event log on the BT server is reporting a List Directory Error:


    Tuesday, July 1, 2014 4:07 PM
  • The user's root directory permissions are as follows:

    Tuesday, July 1, 2014 4:07 PM
  • I am a bit concerned I've run into this:

    http://social.msdn.microsoft.com/Forums/en-US/b9755703-788b-4245-a89c-6c4a38bbd00f/biztalk-2013-sftp-list-remote-directory-error?forum=biztalkgeneral

    Tuesday, July 1, 2014 4:24 PM
  • One more thing...

    Be sure the directory that contains the files, can be read by the BizTalk Service account.

    Chas

    Wednesday, July 2, 2014 4:16 AM
  • We faced an issue , I am not sure if it is related to your issue, that some files not picked up once we are in staging and production servers especially when there are a lot of files in sftp folder

    We resolved the issue by increasing polling interval e.g. 5 minutes 


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    Wednesday, July 2, 2014 6:34 AM
  • UPDATE:

    I installed Cerberus and CompleteFTP on my desktop and ran into the same issues. The out of the box adapter will write to the sFTP location but cannot read. It seems to encounter a list command error no matter what permissions I have configured so just for kicks I installed BitLogic's sFTP adapter. There was a bit of a snafu when adding the adapter. It seems the BitLogic adapter installs with the same alias as the default adapter. I edited that registry setting and then added the adapter and everything went smoothly. The key to edit can be found in this thread :BitLogic SFTP Adapter

    It works PERFECTLY in both directions. 

    My next step is to download BT 2013 R2 and open a ticket with MS. 

    Thx for your help in this matter. All the testing leads me to believe there is a problem with the adapter.


    Friday, July 11, 2014 3:58 PM
  • Hi Philip,

    This is the  issue with SFTP adapter and we have encountered it in one of the assignment . There is some private patch available with MS and i would recommend to connect to MS to get it working .

    I have already mentioned it previously

    http://social.msdn.microsoft.com/Forums/en-US/b9755703-788b-4245-a89c-6c4a38bbd00f/biztalk-2013-sftp-list-remote-directory-error?forum=biztalkgeneral

    Thanks
    Abhishek

    Monday, July 14, 2014 3:30 AM
  • Hi Abhishek,

      Thx. I found your post pretty early in my research. I was hoping to find away around it but it looks like you're right. I will reach out to MS and see what they can provide me as far as a private build.

    In the meantime, I installed BLogic's sFTP adapter and after some initial configuration changes it works perfectly. 

    Monday, July 21, 2014 5:03 PM