none
Ribbon vertical separator in group is no longer displayed in Office 2016 (Word, Visio, ...) RRS feed

  • Question

  • Create a custom XML Ribbon using Custom UI Editor or Addin Customized XML with a separator.

    It is never displayed.

    Any Clue ?

    Sample XML Ribbon :

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <customUI xmlns="http://schemas.microsoft.com/office/2009/07/customui">
      <ribbon>
        <tabs>
          <tab idMso="TabHome">
            <group idMso="GroupEditing" visible="false" />
            <group idMso="GroupClipboard" visible="false" />
            <group id="CustomGroup" label="Editing and Clipboard" insertBeforeMso="GroupFont">
              <splitButton idMso="PasteMenu" size="large" />
              <button idMso="Cut" />
              <button idMso="Copy" />
              <control idMso="FormatPainter" />
              <separator id="Sep1" />
              <button idMso="FindDialog" />
              <button idMso="ReplaceDialog" />
              <menu idMso="SelectMenu" />
              <dialogBoxLauncher >
                <button idMso="ShowClipboard" />
              </dialogBoxLauncher>
            </group>
          </tab>
        </tabs>
      </ribbon>
    </customUI>


    Michel LAPLANE (MVP Visio)

    Friday, February 9, 2018 2:14 PM

All replies

  • Hi LAPLANE Michel - MVP Visio,

    I try to make a test with Word 2016.

    I use code below in Custom UI Editor.

    <customUI xmlns="http://schemas.microsoft.com/office/2009/07/customui">
    	<ribbon>
    		<tabs>
    			<tab idMso="TabHome">
    				<group idMso="GroupEditing" visible="false" />
    				<group idMso="GroupClipboard" visible="false" />
    				<group id="CustomGroup" label="Editing and Clipboard" insertBeforeMso="GroupFont">
    					<button id="button1" label="Button 1" imageMso="HappyFace" size="large" />
     					<separator id="separator" />
     					<button id="button2" label="Button 2" imageMso="HappyFace" size="large" /></group>
    			</tab>
    		</tabs>
    
    	</ribbon>
    </customUI>
    

    Output:

    I also made a test with your code and find that separator is appear in that too.

    One thing you need to check is that when you directly copy the code from above and paste it in custom ui editor then it will add some space in separator tag line. like below.

    So , When you try to validate the code. It will give you an error.

    To solve the error, You need to remove the unnecessary space from that line and again validate it.

    after that if you run the code then it will display the separator.

    Reference:

    2.2.34 separator (Separator)

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by SurrogateMVP Thursday, February 15, 2018 4:26 PM
    Monday, February 12, 2018 3:17 AM
    Moderator
  • I am having the same issue but only on a Microsoft Surface with Windows 10 and Excel 365, all separators, just separators can't be disappeared.

    The same excel file works fine on all other normal laptops with the same windows and Excel 365 version.

    Wired and still working on it to figure out what's wrong.

    Cheers,

    Lily

    Monday, December 3, 2018 8:47 PM