none
net framework 4 problem for windows 7 ultimate x64 RRS feed

  • Question

  • i've ready many posts and tried basically everything on those post in order to get rid of this error. "To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319" sadly this error as also been poping up for some of the games i play as well. i did a little trouble shooting and I got another error: 0x80131700 is not functioning correctly or has been deleted. which is sadly i have no idea how that happened. it also will not allow me to install windows 7 sp1. so what ever this is I've lost and need i've been trying to find it and can't download it. it would seem. beginning to wonder if i need my windows 7 ultimate disc to try and reinstall software and start from strach and hope for the best. so if anyone has any ideas i'm willing to listen. also going to keep reading and looking up information to help me out.
    Wednesday, March 2, 2011 5:38 AM

Answers

  • Hi Viper_VX,

    Thanks for your post.

    According to your desription, I thinks the error message "To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319" should be caused by the .NET Framework 4.0 is not installed in your system.

    Would you pelase go to Start menu -> Control Panel -> Uninstall a program, and check whether you have the components below in the program list:

    If they are already exists in your system, you can try to right-click each program -> Change/Uninstall, and repair them.

    If you do not have these components, you will need to install the .NET Framework 4.0. You can download it from the link below:
    http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    Before install .NET Framework, you should finish the steps below first:

    -          Turn off your anti-virus/antispyware software during installation;

    -          Install the latest Windows updates from the Windows Update site: http://windowsupdate.microsoft.com;

    -          Complete or dismiss Windows Update before installation. (And don't forget to turn it on later)

    -          Clean your %temp% folder (Start Menu >> Run >> Type "%temp%).

    -          Install .NET Framework again (with Administrator privilege).

     

     I hope this helps.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, March 3, 2011 8:24 AM
    Moderator

All replies

  • Hi Viper_VX,

    Thanks for your post.

    According to your desription, I thinks the error message "To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319" should be caused by the .NET Framework 4.0 is not installed in your system.

    Would you pelase go to Start menu -> Control Panel -> Uninstall a program, and check whether you have the components below in the program list:

    If they are already exists in your system, you can try to right-click each program -> Change/Uninstall, and repair them.

    If you do not have these components, you will need to install the .NET Framework 4.0. You can download it from the link below:
    http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    Before install .NET Framework, you should finish the steps below first:

    -          Turn off your anti-virus/antispyware software during installation;

    -          Install the latest Windows updates from the Windows Update site: http://windowsupdate.microsoft.com;

    -          Complete or dismiss Windows Update before installation. (And don't forget to turn it on later)

    -          Clean your %temp% folder (Start Menu >> Run >> Type "%temp%).

    -          Install .NET Framework again (with Administrator privilege).

     

     I hope this helps.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, March 3, 2011 8:24 AM
    Moderator
  • Andrew.Wu,

    Thank you so much! This did work! I have seen many blogs that posted answers to the error message about the .net framework update failing and none of their solutions worked for me until I read yours! I am running Windows 7 Ultimate 64 bit! Thanks, it worked!

    Saturday, March 19, 2011 6:58 AM
  • I'm also having this same problem.

    I JUST finished a clean install of Windows 7 Ultimate 64-bit. Ran all the Windows Updates that are available, and I'm still getting the same error ".NET Framework Initialization Error To run this application, you first must install one of the following versions of the .NET Framework: v4.0"

    I've already ran the dotNetFx40_Fell_x86_x64.exe and then installed the patches and SP's from Windows Update. After that I tried the steps outlined above, clearing the un-installing the .NET Framework components, clearing out the TEMP directory and then re-installing .NET 4.0 with Administrator privelages. Still getting the same error.

    When I run the .NET Setup Verification tool it fails when checking .NET Framework 4 Full, and at the end of the Log file it reads:

    [05/06/11,01:32:55] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [05/06/11,01:32:55] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [05/06/11,01:32:55] ExecutablePath = 'Netfx40TestApplication.exe'
    [05/06/11,01:32:55] FriendlyName = '.NET Framework 4 test application'
    [05/06/11,01:32:55] TimeoutSeconds = '300'
    [05/06/11,01:32:55] WaitOnExit = 'true'
    [05/06/11,01:32:55] Silent = 'true'
    [05/06/11,01:32:55] Launching process 'Netfx40TestApplication.exe' now
    [05/06/11,01:32:55] Process successfully launched. Waiting 300 seconds for it to complete.
    [05/06/11,01:32:56] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [05/06/11,01:32:56] ****ERROR**** Verification failed for product .NET Framework 4 Full

    I'm at a loss now, as I've been at this 5 hours or so, doing research, formatting and doing clean installs, and un-installing and re-installed .NET over and over, only to wind up with the same errors time after time.

    Flanders42


    Friday, May 6, 2011 6:34 AM
  • Yeah so I've been finding. The crazy thing is that it used to work for me! Just up until a few months ago did I start having this problem. Even after clean installs, which really boggles my mind.
    Friday, May 6, 2011 1:15 PM
  • Hi Andrew.wu,

    may i ask why my laptop dont have Microsoft .NET Framework 4 Multi-Targeting Pack? D: i tried to install it but cant.. and i am having same problem as Viper_VX problem.. please help :(
    Thursday, March 7, 2013 6:59 AM
  • what do u mean with clean delete all files?

    Friday, May 23, 2014 6:40 AM
  • what does he mean clean delete all files?

    Friday, May 23, 2014 6:41 AM