none
Version information in OS images RRS feed

  • Question

  • Hi,

    I'd like to store OS design version information in my Windows Embedded Compact 7 OS images. The version number is our own (that is, it has nothing to do with the WinCE version) and is generated by the build server. How do you generally do this? Is there a mechanism provided by WinCE? Or should I simply store the version number in a text file or a registry entry? What do you think is better? Personally I tend towards a text file, because it's the simplest to access...if you're connected to the board via telnet, you simply do a "type \windows\version.txt" and get the version number back. Any thoughts?

    Cheers
    Kartoffelsalat

     

    Wednesday, April 27, 2011 10:12 AM

Answers

  • Even better; prepend your version information string to "CopyRts.txt"
    and your users can also quickly see the version information in the
    "System" control panel applet (tab Copyrights).
     
    I generally use both;
     
    Machine readable info in the registry
    Human readable info in CopyRts.txt
     

    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.
    • Proposed as answer by Vinoth[MCTS] Wednesday, April 27, 2011 1:42 PM
    • Marked as answer by Kartoffelsalat Tuesday, May 3, 2011 12:37 PM
    Wednesday, April 27, 2011 11:58 AM
    Moderator

All replies

  • I did the same by saving the version in a registry entry under HKLM

     

    You can read this using an application, From command line, or a third party remote application like pocket controller.

     

    ----Misbah


    Senior Design Engineer T.E.S Electronic Solutions (Bangalore-India) www.tesbv.com email-misbah.khan@tesbv.com
    Wednesday, April 27, 2011 11:23 AM
  • Even better; prepend your version information string to "CopyRts.txt"
    and your users can also quickly see the version information in the
    "System" control panel applet (tab Copyrights).
     
    I generally use both;
     
    Machine readable info in the registry
    Human readable info in CopyRts.txt
     

    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.
    • Proposed as answer by Vinoth[MCTS] Wednesday, April 27, 2011 1:42 PM
    • Marked as answer by Kartoffelsalat Tuesday, May 3, 2011 12:37 PM
    Wednesday, April 27, 2011 11:58 AM
    Moderator
  • Mmh...oddly enough, my OSes don't display anything in that dialog, not even the default blurb from CopyRts.txt (which IS in the OS image, and which I haven't even modified yet). I don't have to do anything special, right?
    Wednesday, April 27, 2011 2:47 PM
  • WEC7? I've noticed that too... Works fine in CE 6.0 R3... Bug report to MS then...
    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.
    Wednesday, April 27, 2011 10:03 PM
    Moderator
  • Bug report to MS then...
    Stupid question: where does one report bugs in WEC7? Do we need a particular support contract for that?
    Monday, May 2, 2011 9:39 AM
  • Through the normal support channels. You just open a support incident (you get 2 free ones with your purchase of PB) and if it turns out to be a bug you won't get charged (or loose one of your free support incidents).

     

    MVP's have some more entries to the MS CE Core Team and I have reported it through that. MS is looking into it (and the fix will probably be released as a QFE soon).


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.
    Wednesday, May 4, 2011 8:37 AM
    Moderator
  • About 2 hours ago I reported the problem too, using my MSDN support contract as nobody here involved in purchasing PB in the first place knew about those 2 free support incidents.

    Thank you for reporting the bug, I appreciate that. I suppose coming from an MVP they'll give it a bit more weight anyway.

    Wednesday, May 4, 2011 10:19 AM
  • About 2 hours ago I reported the problem too, using my MSDN support contract as nobody here involved in purchasing PB in the first place knew about those 2 free support incidents.


    Read the leaflet inside the Platform Builder box. It's all there (or at least it was for PB 6.0, not sure this has changed for WEC7 as nowadays I have to download it from my MSDN subscription...)

    Thank you for reporting the bug, I appreciate that. I suppose coming from an MVP they'll give it a bit more weight anyway.

    I wish... ;)
    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.
    Wednesday, May 4, 2011 3:29 PM
    Moderator