locked
virtual directory not being configured as an app in IIS RRS feed

  • Question

  • User1417463344 posted

    I moved Webhosts and now I have a broken link under one of my pages. I was told gy Go Daddy to setup my IIS which I have done but we're still down. I'm not the best when it comes to IIS so any help would be very much appreciated. Below is the error,

     

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

     http://altuonline.com.previewdns.com/arklogin/login.aspx?pageid=apps   <- this is the link

    Friday, April 17, 2009 11:43 AM

Answers

  • User-823196590 posted

    As GoDaddy told you, the root of your web site needs to be D:\hosting\altuadmin.  You then need to set the ArkLogin folder as an application.

    What version of ASP.NET are you using?  Your server is currently set to 1.1.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, April 20, 2009 6:42 AM

All replies

  • User-823196590 posted

    You need to set the "arklogin" folder as an applicaiton in the IIS MMC.  If your web host does not provide direct access to do this then they probably at least provide some type of control panel for IIS.

    Friday, April 17, 2009 11:47 AM
  • User1417463344 posted

     I have the option under the control panel to configure the IIS, should I just choose the "arklogin" folder or a specifc file? currently I have it setup to point the file to the login.aspx is this wrong?

    Friday, April 17, 2009 11:52 AM
  • User1417463344 posted

     tomkmvp, what is MMC stand for? I've deleted the directory that I created so I can re-do it from scratch. Should I just point to /root directory/arklogin

    Friday, April 17, 2009 12:30 PM
  • User-823196590 posted

     I have the option under the control panel to configure the IIS, should I just choose the "arklogin" folder or a specifc file?

    Folder - I thought my post was clear on that.

    currently I have it setup to point the file to the login.aspx is this wrong?

    ??? What is "setup to point to the login.aspx"?

    Friday, April 17, 2009 3:26 PM
  • User-823196590 posted
    MMC means Microsoft Management Console, which is what you would use to manage IIS on local or remote machine.
    Friday, April 17, 2009 3:27 PM
  • User1417463344 posted

     just got off the phone with Go Daddy, I'm being told to setup the IIS with the root folder of my website which is "altuadmin" folder then choose "arklogin" folder but that is still not fixing the issue.  Should I only choose the arklogin without the root folder?

    Friday, April 17, 2009 3:37 PM
  • User1417463344 posted

     I've pointed the IIS to the "arklogin" folder by it's self and currently I'm still getting the same error? what am I doing wrong? this was suppose to be a simple transfer.

     

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 47:            by Microsoft that offers a single logon and core profile services for member sites.
    Line 48: -->
    Line 49: <authentication mode="Windows" />
    Line 50:
    Line 51:

    Source File: d:\hosting\altuadmin\ArkLogin\web.config    Line: 49


    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407 

    Friday, April 17, 2009 5:39 PM
  • User-823196590 posted

    As GoDaddy told you, the root of your web site needs to be D:\hosting\altuadmin.  You then need to set the ArkLogin folder as an application.

    What version of ASP.NET are you using?  Your server is currently set to 1.1.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, April 20, 2009 6:42 AM
  • User1417463344 posted

     Tom,

     .Net Runtime Version: ASP.Net 1.1 this is what I have with Go Daddy currently. How do I set the ArkLogin as an application?

     

    Monday, April 20, 2009 9:16 AM
  • User-823196590 posted

    If you were hosting your own IIS that's easy - but since you're on GoDaddy I have no idea on how to use their control panel.  This should be something simple for them to help you with ...

    Monday, April 20, 2009 9:36 AM
  • User1417463344 posted

     yeah, I just found an article on how to do it but I have no access to the IIS within the server.. so that has to be done by them for sure. The challanging part will be is to make them understand on what I need done.

    Monday, April 20, 2009 9:50 AM
  • User-823196590 posted

    There's nothing for them to do.  You use your Hosting Control Center to set your application root.

    http://help.godaddy.com/aticle/3973

    Monday, April 20, 2009 10:07 AM
  • User1417463344 posted

     so under my control panel i have the option checked for "set application" since that option would consider all files within that directory to be part of the application. Was that it you think? that was not the option that was checked.

    Monday, April 20, 2009 10:20 AM
  • User1417463344 posted

     Tom,

     changing that setting changed something but now I have permission issues, will this be handled by GoDaddy since I can't right click the folder within my control panel and change permissions.

    Please try the following:

    • Contact the Web site administrator if you believe this directory should allow execute access.

    HTTP Error 403.1 - Forbidden: Execute access is denied.
    Internet Information Services (IIS)


    Technical Information (for support personnel)

    • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 403.
    • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Configuring ISAPI Extensions, Configuring CGI Applications, Securing Your Site with Web Site Permissions, and About Custom Error Messages.

     

    Monday, April 20, 2009 10:36 AM
  • User1417463344 posted

     found where I can edit the permissions, I gave the folder read and write permission but the error is the same, should I only give the folder one or the other? if so which one?

    Monday, April 20, 2009 10:47 AM
  • User-823196590 posted

    403.1 is not about read and write permissions. See http://support.microsoft.com/kb/318380

    Monday, April 20, 2009 11:01 AM
  • User1417463344 posted

     so if under my control panel the only options I have are the following, the article is talking about MMC which I've asked you in the passed but I do not have direct access to that, have any ideas?

    Inherit (Inherit permissions from parent directory)  
    <input id="FileList-permissions-wr" class="permissions-check" checked="true" disabled="true" type="checkbox"> Read (Directory contents are visible to users)  
    <input id="FileList-permissions-ww" class="permissions-check" disabled="true" type="checkbox"> Write (Applications can write to this directory)  
    <input id="FileList-permissions-reset" class="permissions-check" type="checkbox"> Reset all children to inherit (All subdirectories will be reset to inherit from current directory)

     

    Monday, April 20, 2009 11:13 AM
  • User-823196590 posted

    Did you read the link I referenced?

    403.1 - Execute access forbidden. The following are two common causes of this error message:

    • You do not have enough Execute permissions. For example, you may receive this error message if you try to access an ASP page in a directory where permissions are set to None, or you try to execute a CGI script in a directory with Scripts Only permissions. To modify the Execute permissions, right-click the directory in Microsoft Management Console (MMC), click Properties, click the Directory tab, and make sure that the Execute Permissions setting is appropriate for the content that you are trying to access.
    • The script mapping for the file type that you are trying to execute is not set up to recognize the verb that you are using (for example, GET or POST). To verify this, right-click the directory in Microsoft Management Console, click Properties, click the Directory tab, click Configuration, and verify that the script mapping for the appropriate file type is set up to allow the verb that you are using.

    Again, since you're paying GoDaddy to host your site they should be able to support this.  There must be some equivalent way to do it in their control panel.  If not, you need GoDaddy's direct help to sort it out.

    Monday, April 20, 2009 11:56 AM
  • User1417463344 posted

     looks like I need to be moved either to a virtual dedicated or full dedicated server since that permission cannot be changed since there are other people on my server that will effect their site. That actually makes a little sense, what do you think?

    Monday, April 20, 2009 12:16 PM
  • User-823196590 posted

    It makes no sense.  For any script to run like ASP or ASP.NET, IIS must be set to allow it.  You should not be getting this error. 

    Please Please Please contact GoDaddy for support, they need to help you on this.

    Monday, April 20, 2009 12:32 PM
  • User1417463344 posted

     tier1 is checking with advance server support if they can change the IIS to allow it, if not I'll have to move to a virtual dedicated...i got to get this up and running somehow.

    Monday, April 20, 2009 12:42 PM
  • User1417463344 posted

     I'm being told that I would have to write the code a different way in order to make it work and without moving to a virtual dedicated server.

    Monday, April 20, 2009 1:05 PM
  • User1417463344 posted

     I decided to move to a virtual dedicated server and have been looking at the MMC control panel. Is that where I'm going to be fixing my issue or in the IIS?

    Monday, April 20, 2009 3:21 PM
  • User-823196590 posted

    The MMC is merely a container for managing various things, among them IIS.

    What you want is Start -> Administrative Tools -> Internet Information Services (IIS) Manager

    Monday, April 20, 2009 3:59 PM
  • User1417463344 posted

     ok so for testing purposes, I opened one of my servers. Went to Start> admin tool> opened IIS> picked a folder, right click> went to properties> then home directory tab> and both read/write needs to be checked and also set the Execute permissions to Scripts only or Scripts and Executables?

    Monday, April 20, 2009 4:16 PM
  • User-1853252149 posted

    Is this for ASP.NET or ASP Classic.  Pretty much you want Scripts only either way.

    Also, check the physical file/folder permissions.  These are not in the IIS MMC, just File Manager or whatever else your host lets you use.  Make sure that NETWORK SERVICES has MODIFY or FULL CONTROL on your folders.

    Jeff

    Monday, April 20, 2009 4:29 PM
  • User1417463344 posted

     this is an ASP.net 1.xxx application, so i just checked and make sure the network service logon id has full control of that root folder, right?

    Monday, April 20, 2009 4:39 PM
  • User-823196590 posted

    No.  See http://support.microsoft.com/kb/812614.

    Tuesday, April 21, 2009 9:49 AM
  • User989702501 posted
    Mm... i just replied the same content on the other post :)
    ---
    403.1 - did you configure executable permission?
    http://support.microsoft.com/kb/318380
    ---
    Tuesday, April 21, 2009 1:05 PM
  • User-823196590 posted

    Mm... i just replied the same content on the other post :)
    ---
    403.1 - did you configure executable permission?
    http://support.microsoft.com/kb/318380
    ---

    We were there 13 posts ago!  : )

    Are you having fun yet?

    Tuesday, April 21, 2009 1:21 PM
  • User1417463344 posted

     I now have a shiny new virtual dedicated server that I can RD too etc....so changing the permisson's will be cake walk. However, now when I FTP files they are not showing up on the server....so yeah I'm having a blast!!!

    Tuesday, April 21, 2009 1:25 PM
  • User1417463344 posted

     Tom,

     site is uploaded and i'm back to square one of course with this error,

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 47:            by Microsoft that offers a single logon and core profile services for member sites.
    Line 48: -->
    Line 49: <authentication mode="Windows" />
    Line 50:
    Line 51:

    Source File: C:\Inetpub\vhosts\altuonline.com\httpdocs\arklogin\web.config    Line: 49 

     

    would you mind and giving me the step by step on how and where is MMC to make this folder as an application? I do have "direct" access to the server it's self.

    Wednesday, April 22, 2009 12:06 PM
  • User-823196590 posted

    Assuming that C:\inetpub\vhosts\altuonline.com\httpdocs is your web root, select the "arklogin" folder and click Properties, then click the "Create" button under application settings.

    Wednesday, April 22, 2009 12:52 PM
  • User1417463344 posted

     I made the change to your instructions, but now i'm having this error and i'm totally lost as to what this might be,

    Server Error in '/ArkLogin' Application.

    Server cannot access application directory 'C:\Inetpub\vhosts\altuonline.com\httpdocs\ArkLogin\'. The directory does not exist or is not accessible because of security settings.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Server cannot access application directory 'C:\Inetpub\vhosts\altuonline.com\httpdocs\ArkLogin\'. The directory does not exist or is not accessible because of security settings.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Server cannot access application directory 'C:\Inetpub\vhosts\altuonline.com\httpdocs\ArkLogin\'. The directory does not exist or is not accessible because of security settings.]
    System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263

    [HttpException (0x80004005): ASP.NET Initialization Error]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +983
    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128
     


    Wednesday, April 22, 2009 3:05 PM
  • User-823196590 posted

    Does that folder actually exist?  What NTFS permissions are set on it?  What Operating System are you running?  What images did you try to post?

    Wednesday, April 22, 2009 3:24 PM
  • User1417463344 posted

     all the folders/files are present, the OS is 2003 windows server with SP2, and for which account did you want me to check permissions on the arklatex folder?

    Wednesday, April 22, 2009 4:05 PM
  • User1417463344 posted

     I decided to clear my browser history, and I now get this error. The target link that the preview site is looking at is this - http://72.167.99.184/$sitepreview/altuonline.com/

    and this is the error on the applications link

    Server Error in '/ArkLogin' Application.

    Access denied to 'C:\Inetpub\vhosts\altuonline.com'. Failed to start monitoring file changes.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Access denied to 'C:\Inetpub\vhosts\altuonline.com'. Failed to start monitoring file changes.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80070005): Access denied to 'C:\Inetpub\vhosts\altuonline.com'. Failed to start monitoring file changes.]
    System.Web.FileChangesMonitor.FindDirectoryMonitor(String dir, Boolean addIfNotFound, Boolean throwOnError) +527
    System.Web.FileChangesMonitor.StartMonitoringPath(String alias, FileChangeEventHandler callback) +477
    System.Web.Caching.CacheDependency.Init(Boolean isPublic, Boolean isSensitive, String[] filenamesArg, String[] cachekeysArg, CacheDependency dependency, DateTime utcStart) +1556
    System.Web.Caching.CacheDependency..ctor(Boolean isSensitive, String[] filenames, DateTime utcStart) +50
    System.Web.Configuration.HttpConfigurationSystem.GetCacheDependencies(Hashtable cachedeps, DateTime utcStart) +154
    System.Web.Configuration.HttpConfigurationSystem.ComposeConfig(String reqPath, IHttpMapPath configmap) +760
    System.Web.HttpContext.GetCompleteConfigRecord(String reqpath, IHttpMapPath configmap) +434
    System.Web.HttpContext.GetCompleteConfig() +48
    System.Web.HttpContext.GetConfig(String name) +195
    System.Web.CustomErrors.GetSettings(HttpContext context, Boolean canThrow) +20
    System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow) +40
    System.Web.HttpRuntime.FinishRequest(HttpWorkerRequest wr, HttpContext context, Exception e) +480

     

     


    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407

     

    Wednesday, April 22, 2009 4:43 PM
  • User-823196590 posted

    You can't use folders with .com in the name ...
    http://support.microsoft.com/?kbid=275601

    Wednesday, April 22, 2009 5:34 PM
  • User-2064283741 posted

     

    You can't use folders with .com in the name ...
    http://support.microsoft.com/?kbid=275601

    You can use folders and websites with .com etc in them. There is no issue with that I use them all the time. The above article is for creating virtual directories under the sites and that makes sense that you cannot have a VD with .com

    Wednesday, April 22, 2009 9:02 PM
  • User1417463344 posted

     I've followed method 3 from Tom's suggestion,

    If your computer is running IIS 6.0, grant the required permissions on all the folders in that hierarchy to the Network Service account. To do this, follow these steps:

    1. In Windows Explorer, locate the application folder or the virtual directory that contains the content (for example, D:\MyWeb\Users\MainDirectory\MyApplication).
    2. Right-click the folder, and then click Properties.
    3. On the Security tab, click Add.
    4. Type <var>ComputerName</var>\NETWORK SERVICE (for example, on a computer that is named Webdev, type Webdev\NETWORK SERVICE), and then click OK. If impersonation is turned on, you must also add the impersonated accounts.
    5. Allow the following permissions for the Network Service account (and for the impersonated accounts if impersonation is turned on):
      • Read & Execute
      • List Folder Contents
      • Read

    6. Click OK to close the Properties dialog box and to save the changes.
    7. Repeat steps 2 through 6 for all the folders in the hierarchy of the path. For example:
      • D:\MyWeb\Users\MainDirectory
      • D:\MyWeb\Users
      • D:\MyWeb
      • D:\
    Now that directory is displaying just fine!!!   Tom, I can't thank you enough for your help on this. My next issue is that the contents of other directories are displaying but what's on the pages do not, pictures, words etc....is that because it's in test mode or is that a coding issue?

    I think the other directories are Flash, which I have never touched.

     

    Thursday, April 23, 2009 9:59 AM
  • User-823196590 posted

    My next issue is that the contents of other directories are displaying but what's on the pages do not, pictures, words etc

    What does this mean?  What happens exactly?

    Thursday, April 23, 2009 10:34 AM
  • User1417463344 posted

     for example, the link i click on is "services" in real life with my current host you'll see what's actually on the page, www.altuonline.com and click services. Under my current setup with Go daddy, the page its self loads up but the icons that are on the page do not.


    Thursday, April 23, 2009 10:59 AM
  • User-823196590 posted

    Looks good to me.

    Thursday, April 23, 2009 11:35 AM
  • User1417463344 posted

     see, your looking at that page under Click2bind not with Go Daddy, my current page when I preview it, do not have all the icons that you see on that page. Inland marine, Umbrella/Excess etc....none of those are showing up. Issue is the same on all the other pages as well.

    Thursday, April 23, 2009 11:42 AM
  • User-823196590 posted

    So what you're saying is the flash is not loading?

    You may need to enable the mime-type for flash.
    http://support.microsoft.com/kb/326965

    Thursday, April 23, 2009 12:03 PM
  • User1417463344 posted

     according to the folks that designed the site it's not Flash, I asked him if the site was designed with Flash and this was his reponse back:

     "No, only to individual Access files usually located in the fpdb folder for each app.  i.e. newsticker, docmanage, docview"

    I asked him to send me a screen shot of our website on his IIS...so hopefully he'll play ball and send that over.

     

     

     

     

     

     

     

     

     

     

    Thursday, April 23, 2009 12:35 PM
  • User-823196590 posted

    A screen shot does me no good.

    Check your IIS log file to see what is getting logged for the resources that do not display correctly.  Specifically look at the status and sub-staus codes that are getting logged as they will tell us exactly what is going on.  You can reference what those codes mean and how to fix the issue with this MSKB:

    http://support.microsoft.com/kb/318380

    Thursday, April 23, 2009 12:47 PM
  • User1417463344 posted

     is there a simple way to look at the log file? there is way to much data on that....

    Thursday, April 23, 2009 1:38 PM
  • User-823196590 posted

    If notepad or wordpad are too cumbersome, try importing it into Excel.

    Thursday, April 23, 2009 3:01 PM
  • User1417463344 posted

     per that MSN support article I don't see any of the codes on the log file,  ohh also, have you seen how many people have viewed this thread...is it me being really stupid or is this really a complex issue?

    #Software: Microsoft Internet Information Services 6.0
    #Version: 1.0
    #Date: 2009-04-23 07:28:40
    #Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
    2009-04-23 07:28:40 W3SVC30608 WEBSERVER 72.167.99.184 GET /Index.html - 80 - 208.80.195.45 HTTP/1.0 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+SIMBAR+Enabled;+SIMBAR={50D75E47-433E-42fa-BE88-5834D1BF4DE7};+ZangoToolbar+4.8.3) - - 72.167.99.184 200 0 0 6807 186 453
    #Software: Microsoft Internet Information Services 6.0
    #Version: 1.0
    #Date: 2009-04-23 13:20:28
    #Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /Index.html - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True - altuonline.com 200 0 0 4753 576 0
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll altuonline.com/ 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True - 72.167.99.184 200 0 0 4851 656 578
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /scripts/flash_detect.js - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ altuonline.com 200 0 0 6376 572 0
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll altuonline.com/scripts/flash_detect.js 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://72.167.99.184/$sitepreview/altuonline.com/ 72.167.99.184 200 0 0 6474 679 218
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /images/logosm.jpg - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ altuonline.com 200 0 0 4329 595 0
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /fpdb/external.html - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ newsticker 404 0 3 1819 535 0
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /121x172truck.swf - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ ads 404 0 2 1819 526 0
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll newsticker/fpdb/external.html 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://72.167.99.184/$sitepreview/altuonline.com/ 72.167.99.184 200 0 0 1913 642 93
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll ads/121x172truck.swf 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://72.167.99.184/$sitepreview/altuonline.com/ 72.167.99.184 200 0 0 1906 633 93
    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll altuonline.com/images/logosm.jpg 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://72.167.99.184/$sitepreview/altuonline.com/ 72.167.99.184 200 0 0 4427 702 156
    2009-04-23 13:20:30 W3SVC30608 WEBSERVER 72.167.99.184 GET /main.swf - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ swffiles 200 0 0 122900 611 1031
    2009-04-23 13:20:30 W3SVC30608 WEBSERVER 72.167.99.184 GET /sitepreview/sitepreview.dll swffiles/main.swf 80 - 12.52.253.27 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://72.167.99.184/$sitepreview/altuonline.com/ 72.167.99.184 200 0 0 122992 718 1437

    Thursday, April 23, 2009 3:21 PM
  • User-823196590 posted

    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /fpdb/external.html - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ newsticker 404 0 3 1819 535 0

    2009-04-23 13:20:28 W3SVC30608 WEBSERVER 72.167.99.184 GET /121x172truck.swf - 80 - 72.167.99.184 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.9.0.9)+Gecko/2009040821+Firefox/3.0.9+(.NET+CLR+3.5.30729) locale=en-US;+PLESKSESSID=afea3de8be7a6c65ade385fa1ee2969c;+psaContext=domains;+BarExpanded=True http://altuonline.com/ ads 404 0 2 1819 526 0

    These two are not found with a 404 0 - meaning they don't really exist.

    This is really hard for me to troubleshoot because you're not giving me much to go on. 

    If I browse to http://72.167.99.184/ everything looks fine to me.

     

    Thursday, April 23, 2009 5:25 PM
  • User1417463344 posted

     awww.....well I'm not sure what is going on because you are 100% right. The site is fully functional when I browse to it via the IP address.

    Thursday, April 23, 2009 5:41 PM
  • User1417463344 posted

     what's the fastest way to find which file to edit if I wanted to make change on the front page of the website?

    Friday, April 24, 2009 11:41 AM
  • User-823196590 posted

    Look in the folder for the root of the site.

    Friday, April 24, 2009 12:31 PM
  • User1417463344 posted

     I'm looking at the files, but there are several of them. I need to get rid of the line "site designed by Click2bind"

    Friday, April 24, 2009 12:45 PM
  • User-823196590 posted

    You need to look at the default documents setting.  They are listed in priority order.  Determine which one is being used on your site.  In my example, default.htm will be used first.  If it does not exist, then default.asp will be used.

    Friday, April 24, 2009 1:21 PM
  • User1417463344 posted

     mine has index.html first, then a bunch of other index.xxx files, all the way on the bottom are the default.xxx files   how do you add screen shots in the reply?

    Friday, April 24, 2009 2:27 PM
  • User1417463344 posted

     I found the file, I have opened it with ASP 05 and I'm getting a permission security error.

    <title>Security Exception</title><style> body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } </style>

    Server Error in '/ALTU Website from today' Application.

    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [SecurityException: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
       System.Reflection.Assembly._GetType(String name, Boolean throwOnError, Boolean ignoreCase) +0
       System.Reflection.Assembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase) +42
       System.Web.UI.Util.GetTypeFromAssemblies(ICollection assemblies, String typeName, Boolean ignoreCase) +145
       System.Web.UI.TemplateParser.GetType(String typeName, Boolean ignoreCase, Boolean throwOnError) +73
       System.Web.UI.TemplateParser.ProcessInheritsAttribute(String baseTypeName, String codeFileBaseTypeName, String src, Assembly assembly) +111
       System.Web.UI.TemplateParser.PostProcessMainDirectiveAttributes(IDictionary parseData) +279
    
     

    Friday, April 24, 2009 2:56 PM
  • User-823196590 posted

    how do you add screen shots in the reply?

    The images need to be on an internet accessible web server. When you use the "Insert/Edit Image" button, you paste in the URL to the image in the "Image URL" text box.

    Friday, April 24, 2009 3:23 PM
  • User1417463344 posted

     Tom,  I switched the DNS servers a few hours ago and now that application link from the site is showing this error message again, nothing on the server or the configuration was changed and this was working fine before I switched the DNS servers, what could be the problem.

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 46:            by Microsoft that offers a single logon and core profile services for member sites.
    Line 47: -->
    Line 48: <authentication mode="Windows" />
    Line 49:
    Line 50:

    Source File: C:\Inetpub\vhosts\altuonline.com\httpdocs\docview\web.config    Line: 48 

    Saturday, April 25, 2009 12:53 PM
  • User-2064283741 posted

    I don't understand where you are getting this error.

    I have been to www.altuonilne.com and it is hosted on the godaddy servers (IP:72.167.999.184) and looks fine.

    Actually there is a slight glitch in your site when viewed in Firefox as

    <%@ Page Language="C#" ContentType="text/html" ResponseEncoding="iso-8859-1" %> 

    appears at the top of every page but that was there in the previous versions hosted on the other servers (Click2bind). So chat to the devs so they can fix this.

    Saturday, April 25, 2009 2:28 PM
  • User-823196590 posted

    this was working fine before I switched the DNS servers, what could be the problem.

    Quite Clearly, what ever server is now serving the site does not have the "docview" folder set as an application.

    Monday, April 27, 2009 10:52 AM
  • User1102492756 posted

     Tom,  it was my browser that was displaying a cache page. And i've been working way to much to even think of clearing out my browser history, page is up and running fine.

    Monday, April 27, 2009 5:23 PM
  • User1102492756 posted

     the devs won't speak to me since I pulled the hosting account from Click2bind. Do you have any suggestions on how to fix that or what's causing that?

    Wednesday, April 29, 2009 10:32 AM
  • User-823196590 posted

    Fix what, the browser caching the page?

    Wednesday, April 29, 2009 1:03 PM
  • User1102492756 posted

     to fix the code so that this line does not appear on the page in Firefox

    <%@ Page Language="C#" ContentType="text/html" ResponseEncoding="iso-8859-1" %>

    Wednesday, April 29, 2009 1:11 PM
  • User-823196590 posted

    I would have to see the source of your default page to see why that is happening.

    Wednesday, April 29, 2009 1:55 PM