none
Why is the InfoPath Data Connection Wizard failing? RRS feed

  • Question

  • I am running SharePoint Enterprise on a local VM. I am able to connect to the server using SharePoint Designer 2010 without issue.

    However, when I use InfoPath, the Data Connection Wizard fails.

    If the entered URL is anything but http://domain/sites, the connection fails with "The operation could not be completed".

    If URL ends at /sites/, I am queried for my Farm credentials, so I know that the connection is being made, but the credentials are rejected.

    I have burned a few hours on this issue. Can anyone help?

    - I have InfoPath Form Services enabled

    - I have a form library

    - I have create a list to connect to

    Wednesday, December 14, 2011 8:47 PM

Answers

All replies

  • We need more info.  Connecting to the /sites/ managed path is a red herring - there is nothing to connect to there, so no credentials are going to work.  Have you created a root site collection at http://domain?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, December 14, 2011 9:39 PM
  • This may be the known issue where you have to have a site collection at the root of the web application in order to establish data connections to sub site collection entities.

     

    That is, if the only site collection under http://domain web app is '/sites/', then you'll need to crete an http://domain/ site collection too.

     

    See this for reference (i.e. to confirm this is the behavior you're experiencing): http://vspug.com/ssa/2010/03/15/infopath-2010-cannot-connect-to-sharepoint-2010/

     

    HTH,

     

    Chris

    • Marked as answer by Emir Liu Friday, December 23, 2011 2:05 AM
    Wednesday, December 14, 2011 9:42 PM
  • Great feed back, thank you. I created a Site Collection at the top level using the Blank Site template.

    I was able to get further, but am now getting the following error:

    "This feature requires SharePoint Server 2010 or greater with InfoPath Forms Services enabled."

    But then I see that I need to enable Enterprise Site Collection features for the new top level site that I have created.

    Once I do that, the error goes away and I can connect!

    • Edited by mmcglynn Friday, December 16, 2011 3:40 PM
    Thursday, December 15, 2011 4:59 PM
  • Correct...the Blank Site template does not enable the IPFS feature.
    Thursday, December 15, 2011 6:48 PM
  • mmcglynn, why is that a problem to activate the Enterprise Site Collection Feature??  Do you not have Enterprise?  If not, then you can't do browser forms.

    Earlier, you said you had IPFS "enabled," but there is nothing to enable other than making sure the Enterprise features are turned on.  There is no specific IPFS toggle.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Emir Liu Friday, December 23, 2011 2:05 AM
    Friday, December 16, 2011 6:21 AM
  • Thank you, I wasn't aware of that. Do other templates enable IPFS? I didn't have a particular reason for choosing the site templates, so it would be good to know going forward what would have been a better choice.
    Friday, December 16, 2011 3:41 PM
  • Thank you for your comments Clayton, I edited my response, indicating that I am now able to connect InfoPath designer to SharePoint.
    Friday, December 16, 2011 3:43 PM
  • Team Sites enable IPFS right OOTB.

     

    Please mark helpful and answering posts at your convenience.

     

     

    Thanks,

     

    Chris

    Friday, December 16, 2011 3:57 PM
  • Thank you for your comments Clayton, I edited my response, indicating that I am now able to connect InfoPath designer to SharePoint.

    So is your question answered?  Be sure to always mark your threads as answered when you've gotten what you need.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Saturday, December 17, 2011 4:43 AM