locked
crystal report not visible on client computer RRS feed

  • Question

  • User1131170801 posted

    Sir, 

    VS2010

    I have to pcs one is treated as Server and Development Machine.  VS2010 and Cr13 are installed on it and the all the files related to site are kept in D:\actweb folder . 

    As per ur guidance I have pasted the viewere folder in the D:\Actweb folder as well as on the Root of D:\. 

    The report is easily display without any error on Server but it is not visible and no error is thrown on client.  But I see that on the same page there is a gridview which is working fine on both client and server. 

    Pl. guide

    Thursday, February 13, 2014 10:32 PM

All replies

  • User-425639139 posted

    Most likely the Crystal Report Viewer Active X is not enabled/installed on your Client side. You will need to enable it on Internet Explorer or whatever browser you are using.

    Friday, February 14, 2014 4:26 AM
  • User1131170801 posted

    Do we need to enable crystal report on Client Side, How can v? Pl. explain.  How u can enable on each client?  Why I am not able to see the report when application is run through IIS even on server.

    Thanks

    Friday, February 14, 2014 1:24 PM
  • User-97501952 posted

    Hello,

    How about the issue now? Has it been solved?

    Maybe the similar issue in link below will help you.

    Crystal Reports not working on client

    Saturday, February 22, 2014 8:37 AM
  • User1131170801 posted

    Thanks all

    still not able to run crystal report on client.  The report is visible only in debugging mode.  Even on server itself not able to see report through IIS:

    Regards

    Friday, March 21, 2014 3:04 PM
  • User1131170801 posted

    Somebody pl. guide and help me

    Sunday, March 23, 2014 3:41 AM
  • User-578610739 posted

    Hi Dear,

    Please check that any other report display or all report are not display? I think you need crystal report runtime. So

    Have you installed the Crystal Reports Runtime on the client machine? (Refer link :- http://www.codeproject.com/Questions/572406/Crystalplusreportplusnotplusvisibleplusonplusclien)

    https://scn.sap.com/thread/2090964

    For the easiest way to find solution is, put any hardcore value in a report. and deploy. just check that report will display. So you can get idea about your coding side not for technicality of crystal report side like odbc setting, db connection issue, runtime report viewer.

    Some time your installed product is not appropriate as per framework. So installed as per that.

    Monday, March 24, 2014 1:16 AM
  • User1131170801 posted

    Sir

    I am talking about asp.net application.  So we cann't install crystal report runtime on each client.  

    I have made this clear that I am able to see the report while debugging mode through visual studio 2010 but either on client machine or on the same machine (server) through IIS the report is not visible.

    Pl. help.      If any expert can help through remote sharing he is welcomed. 

    Thanks

    Monday, March 24, 2014 12:09 PM
  • User-37275327 posted

    If i understand your question correctly, you are not seeing the CR properly after hosting on IIS. 

    It seems that your hosting folder can not colmmunicate with aspnet_client folder. what you can do is create a virtual folder inside your application folder as the same name and point to aspnet_client folder in C:\inetpub\wwwroot.

    Wednesday, March 26, 2014 11:02 PM
  • User1131170801 posted

    Sir, 

    I tried the setting u explained. Even I tried to paste the folder from wwwroot  into the applicaiton directory.  I wish to make clear that I am not using the default port i.e. 80, instead of that I am using 82 as port. 

    Pl. guide

    Thanks

    Thursday, March 27, 2014 6:56 AM