locked
Expression Blend 3 is full of bugs RRS feed

  • Question

  • I am currently following several tutorials in a book for Expression Blend 3 + SketchFlow on Windows 7.

    I have two gradient filled rectangles with one on top of the other in the center of my grid.  I attempted to rotate the bottom rectangle by hold down the top right corner. Instead of rotating, the rectangle moves to the top left corner.   When I let go of the mouse, the white background grid disappears and the following error is displayed:

    An Exception Was Thrown

    AccessViolationException: Attempted to read or write protected memory.  This is often an indication that other memory is corrupt.

    StackTrace: (too big to copy)

    InnerException: None

    So I decide to skip this tutorial and move ahead a little.  So I close and attempt to reopen the project and I get the following:

    Microsoft Expression Blend 3 has stopped working.

    So I decided to try Blend again.  This time the program started up correctly.  

    So I put my rectangles back.  I selected the Brush Transform tool and attempted to use it to rotate the gradient.  This time everything on the screen went away.  The white user control is gone.  I have no ideal what happen, but this happens every time.  


    Is there an update or fix for this?????

    Sunday, December 20, 2009 9:53 PM

All replies

  • It took me a while to get used to it, but the mouse dragging behavior is picky about where the mouse is when you press the button.  For rotation, you need to make sure that the cursor changes into a curved line with arrows on either end.  When you see that cursor, then click and drag to rotate.

    I actually haven't had any crashes yet, but until today I was running Expression Studio on Windows XP SP3.  I am now on Vista x64 and we'll see how that goes (crossing fingers).
    Monday, December 21, 2009 5:44 PM
  • Tony,

    Scanning our fixed and open bugs database, I don't see anything that appears to correspond to what you are reporting.

    Is this Blend 3 RTM? Or a preview / beta version?
    Silverlight or WPF project?
    Which book are the tutorials in?

    Best would be if you could send us the full details of the crash so we can follow up on this.  Especially the Stack Trace and any Watson dump files.  (email me the files directly at rick.keeney@microsoft.com might be the most convenient)

    - Rick


    Tuesday, December 29, 2009 5:25 PM
  • Hello Rick.  This is a full version of Blend 3.  I was working on a Silverlight project.  The name of the book is called Foundation Expression Blend 3 with Silverlight by Victor Gaudioso.  I review how to do the dump and I will email you. 
    Wednesday, December 30, 2009 4:01 PM
  • Hallo

    I have the same Problems with Expression Blend + Design, when I try to save a File (empty or not) to my local Disk or a networkshare.
    That makes the whole Studio unusable for me... I realy need a solution.

    I work with Windows7 64bit and Expression Studio 3 (full Version).

    Greets
    Marcel
    redM
    Thursday, December 31, 2009 3:45 PM
  • I'm running win7 64 and have saved hundereds of Blend 3 files, local and to home server - never a problem.
    what hardware are you using, do you have all the latest drivers and firmware updates?
    Thursday, December 31, 2009 5:26 PM
  • Hey TonyP
    In an attempt to help out, I have tryed to duplicate this problem.
    all I can say is that with Blend3 RTM, win7 64 - I can get any strange behavior or crashes
    Whem I upgraded from vista to win7 I had a vidio driver problem that was making all kind of unexpected behaivior. maybe new driver would help you.
    just an idea.
    good luck.
    Thursday, December 31, 2009 5:35 PM
  • Hello Mike,

    I wasn't able to send the dump because it was too large.  How did you know you had video driver problems after the upgrade?  Nothing occurred on my end that lends me to believe that would be the cause of my problem.  
    Friday, January 1, 2010 7:59 PM
  • BTW,  I am using a Dell Vostro 1720.   It is 64-bit with 8GB of RAM.  
    Friday, January 1, 2010 8:01 PM
  • Hi

    @MikeGreenway: I am using a ASUS Notebook with up to date Drivers.


    I played a bit with my Expression Design, to find the Problem.

    The Exception is only thrown, wen I open a new document with a customized Size (220x55 px, for example) and try to save it (with and without content).

    When I open a new document with standard Format (640x480 px), save it (local or to the network), it works fine.
    After that I can change the format to my custom format and save it well...

    Maybe that will help...

    Regards
    Marcel
    redM
    Saturday, January 2, 2010 2:18 PM
  • // How did you know you had video driver problems after the upgrade?
    The OS was telling me and some game weren't acting right.
    Sunday, January 3, 2010 1:10 AM
  • Hi redM

    I just tryed what you said "The Exception is only thrown, wen I open a new document with a customized Size (220x55 px, for example) and try to save it (with and without content)."

    saved fine with and without data

    I don't know?

    Mike Grrenway
    Sunday, January 3, 2010 1:13 AM
  • Hmmmm...

    Thanks for trying.
    Now I know a workaround and I can live with it.

    Maybe it is a sideeffect with other SW on that notebook.

    Regards
    redM
    redM
    Sunday, January 3, 2010 12:20 PM
  • Hello Tony, I am happy to hear you are reading my book but I am at the same time sorry to hear you are having these strange issues.  I have never experienced anything like you are seeing either.  Have you tried another computer to see if you get the same results?  When you do resolve your issue and start working through my book again, feel free to email me if you get stuck and I will help you out.  wpfauthor at gmail dot com.

    Victor Gaudioso
    Thursday, January 7, 2010 3:23 PM
  • Hello Victor,

    I am going to try to install the software on a XP machine and see what happens.  I'll keep you guys updated.
    Wednesday, January 13, 2010 4:40 AM
  • Hello TonyP, I have the same problem with Expression Blend 3, I see here that you got yourhands on potential solution for that problem, so I would really be grateful if you email me how to do the dump as well if you have already got the solution!


    Thank you very much !

    Stephan
    علاج الصلع
    Monday, January 25, 2010 7:31 AM
  • I am constantly running into this problem as well.  I am running on Vista64 with 4G memory, working on a sketchflow project with about 50 screens in the Sketchflow map, and using WPF controls and making use of transparency and gradients in opacity mask. 

    Usually Expression crashes after a period of time of making changes to a page.  It doesn't even have to be a page with lots of elements, just lots of changes.  If I click on an object on the screen it takes a while to update the properties pane with the options for that kind of object.  Progressively, it updates the properties screen slower and slower until it hangs for a few seconds and turns the screen black.  Then it comes back and the same thing happens each time I click on an element.  Finally it gives the error and crashes.  But even if I haven't gotten so far as having the few seconds of hang time - if I run the project it can push it over the edge.  Expression crashes, but the runtime still comes up and I can work through the runtime on the screen.  I restart Expression and everything's fine for a while and then it happens all over again.

    If I look at the memory used by blend.exe in the Windows Task Manager, opening Expression starts out at 65,388K.  then after opening up the project it's at 173,476K.  By the time it crashes the memory usage gets up towards 1GIG of memory.  For example, right now it is at 739,328K.  By comparison, Outlook is running at 104,536K. 

    even after saving each file it doesn't seem to release the memory. but I've learned to save often, and restart Expression after a period of time before it starts hanging or a crash occurs.
    Thursday, February 11, 2010 10:36 PM
  • bluejay,
    You may be running into a SketchFlow Map memory leak. Please contact me: bpappas (at) microsoft (dot) com and I'd like to see if I could help you.

    Thanks,
    Bob

    Friday, February 12, 2010 2:58 PM
  • Any update on this memory leak issue?  I am experiencing the same issue as bluejay.  I have a Dell Vostro 1520, Intel Core2 Duo (T6670), 8 Gb ram.  Running Win 7 64-bit.

    With full install of Blend 3, I'm working with SketchFlow and things start slowing down after just a little while working in it...especially with animations.  Just a few minutes ago Blend stopped responding.  When I checked the resource monitor, Blend was consuming approx 1.7Gb memory by itself (apart from the OS/other processes).

    Tim

    Wednesday, May 19, 2010 2:26 PM
  • To give another update - I just got an exception when building my project:

    Xap packaging failed.  Exception of type 'System.OutOfMemoryException' was thrown.

    This was after about 30 minutes of having Blend open.  Task Mgr currently shows Blend holding about 1.3Gb of memory.

    Wednesday, May 19, 2010 3:19 PM
  • If you're seeing this issue when working with animations, it's most likely related to the animations and not to the map.  You may want to try turning off the thumbnails in the Options menu. Navigate to Tools/Options/SketchFlow and uncheck the checkbox for Generate thumbnails for SketchFlow animations.  If this doesn't solve the problem, I'd be very interested to see your project, both to see if I can repro on Blend 3 and, right now more importantly as there's still something we might be able to do about it, to see if it repros in Blend 4.  kellycan@microsoft.com
    • Proposed as answer by Tim SF Wednesday, May 19, 2010 5:40 PM
    Wednesday, May 19, 2010 4:26 PM
  • Turning off the thumbnails did the trick.  Blend seems to be behaving - staying between 250 - 300mb for the current project I have open, even when creating a number of new animation states.  Thank you.

    Tim

    Wednesday, May 19, 2010 5:40 PM
  • We really think we've cleared this problem up in Blend 4, so if you do have a chance to check that out, let me know.  Glad that you're running again in the meantime though, and sorry for the inconvenience.
    Wednesday, May 19, 2010 5:44 PM
  • So far from what I can tell this problem is not fixed in Blend 4(rtm). I am running Windows 7 (x86) 4GB RAM.

    Every time I build my solution, or any solution as simple as a single button on a blank page, the memory usage of Blend will climb and climb and eventually give me an out of memory exception.\

    Any more word on this yet?

     

    Thanks!

    Monday, July 12, 2010 2:52 PM
  • I just build simple and very complex projects in both silverlight and sketchflow (Blend 4). I watch the meomory in task manager, for a long time ..... No Problem.
    Monday, July 12, 2010 4:41 PM
  • Thanks for the confirmation Mike.

    Regarding this issue: Every time I build my solution, or any solution as simple as a single button on a blank page, the memory usage of Blend will climb and climb and eventually give me an out of memory exception.

    The thing to note is that as you keep building, the memory usage of Blend will keep climbing. But for a simple project with just a Button in it, you can be assured that it will a LONG time before Blend will run out of memory. If you are just using process explorer, you will see memory go up for a while, but eventually it will be garbage collected, and hence will fall back.

    For your more complex project, my guess is that you do have a large executable or library (can you check the file size of this on disk)? This will result in more and more memory being consumed as you are building the project, and one possible workaround then for this issue is to try to reduce the size of the binary (for example, by removing any large assets or fonts you may have embedded so that they get loaded from the XAP or disk).

    Thanks,
    Unni


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, July 12, 2010 6:39 PM
  • Hello, I am having same issue with Expression Blend + Design, problem is much similar to that one redM mentioned. I have Dell Studio 1555, Vista32 with 4G memory
    Any feedback would be appreciated.

    Thanks
    Sara
    Thursday, July 29, 2010 9:52 PM