locked
Visual Studio 2015 Preview could not run the samples

    Question

  • I downloaded the samples from code.msdn.microsoft.com/windowsapps/Windows-8-Modern-Style-App-Samples

    I used Visual Studio 2015 Preview to build the samples and run the app by clicking on the Local Machine or the Simulator, It returns an Error:

    Unable to activate Windows Store app 'Microsoft.SDKSamples.ApplicationViews.CS_8wekyb3d8bbwe!SDKSample.App'. The activation request failed with error ‘The app didn’t start’.

    Then I opened the Event Viewer and saw an Error:

    The server SDKSample.App did not register with DCOM within the required timeout.

    Is there any solution for this?... Please Help!

    Monday, January 19, 2015 7:12 AM

All replies

  • Keep in mind that the samples were written for Windows 8.1/Visual Studio 2013. If they don't work on newer versions, you'll have to wait for newer samples to be released.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, January 19, 2015 1:22 PM
    Moderator
  • Thanks for your answer.

    Today I use visual studio 2015 preview to create a blank new application, compile and run it. I got the same error.

    Tuesday, January 20, 2015 5:04 AM
  • I solved this issue with the tools -- AppsDiagnostic.diagcab
    Tuesday, January 20, 2015 5:13 AM
  • Now the issue took place again. AppsDiagnostic.diagcab did not work.

    I uninstalled the visual studio 2015 preview and installed visual studio 2015 CTP 5 but this issue still exist.

    Thursday, January 22, 2015 8:19 AM