none
Net framework 3 and 3.5 install error. RRS feed

  • Question

  • I have ben having trouble with installing version 3 for some time now. I have tried all of the fixes I can find using google and on here. ( some I don't understand).
    I have downloaded the install files for all the previous versions I have on my computer, uninstalled and reinstalled them, used the clean up tools inbetween but still no joy.
    the error code I am getting is as follows.

    Error Signature
    EventType : wap10setup     P1 : 13165     P2 : 3.0.04506.30_waprtm_x86_sfx    
    P3 : pr     P4 : inst     P5 : f     P6 : wic installer     P7 : baseret_failure
    P8 : -     P9 : 1603     P10 : -

    Any help would be very welcome.

    Thanks

    Tom
    Monday, February 8, 2010 11:03 AM

Answers

  • Hi Tom,

    Thank you for your post.

    Some clarification with you:
    What's your OS?

    For error code "1603", it's a common message that means "fatal error during installation".

    For further troubleshooting, could you please help me to try the following points?

    If you're running XP or Windows Server 2003:
    1. Use Cleanup tool to remove .NET Framework 3.5 >> 3.0 >> 2.0 in order
    2. Download .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
    3. Install this package

    4. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.
    (Please follow the following steps to collect the log files)

    If you're running Vista or Windows Server 2008:
    1. Check whether you have turned on the windows feature of .NET Framework 3.0.
    Please go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check the box next to Microsoft .NET Framework 3.0.
    2. Use Verification Tool to verify .Net Framework 2.0, 3.0. If .Net Framework 2.0 and 3.0 cannot be verified on your computer, you can try to follow the steps mentioned in the following blog to repair the .NET Framework 2.0 and 3.0.
    See: http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx
    3. If .NET Framework 2.0, 3.0 are verified successfully but the installation still fails, please collect the log file.
    (Please follow the following steps to collect the log files)

    If you're running Windows 7:
    NET Framework 3.5 with SP1 is shipped with it as one of OS component.
    This means, you have the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes on Windows 7. They are OS components. We don't need to manually install it.
    Please check whether you have turned on the windows feature of .NET Framework 3.5.1. Go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check the box next to Microsoft .NET Framework 3.5.1.


    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Download .NET Framework 3.5 Service Pack 1 (Full Package) and install it
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Thursday, February 11, 2010 8:32 AM typo
    • Marked as answer by YiChun Chen Monday, February 15, 2010 4:28 AM
    Wednesday, February 10, 2010 9:17 AM

All replies

  • Hi Tom,

    Thank you for your post.

    Some clarification with you:
    What's your OS?

    For error code "1603", it's a common message that means "fatal error during installation".

    For further troubleshooting, could you please help me to try the following points?

    If you're running XP or Windows Server 2003:
    1. Use Cleanup tool to remove .NET Framework 3.5 >> 3.0 >> 2.0 in order
    2. Download .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
    3. Install this package

    4. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.
    (Please follow the following steps to collect the log files)

    If you're running Vista or Windows Server 2008:
    1. Check whether you have turned on the windows feature of .NET Framework 3.0.
    Please go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check the box next to Microsoft .NET Framework 3.0.
    2. Use Verification Tool to verify .Net Framework 2.0, 3.0. If .Net Framework 2.0 and 3.0 cannot be verified on your computer, you can try to follow the steps mentioned in the following blog to repair the .NET Framework 2.0 and 3.0.
    See: http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx
    3. If .NET Framework 2.0, 3.0 are verified successfully but the installation still fails, please collect the log file.
    (Please follow the following steps to collect the log files)

    If you're running Windows 7:
    NET Framework 3.5 with SP1 is shipped with it as one of OS component.
    This means, you have the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes on Windows 7. They are OS components. We don't need to manually install it.
    Please check whether you have turned on the windows feature of .NET Framework 3.5.1. Go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check the box next to Microsoft .NET Framework 3.5.1.


    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Download .NET Framework 3.5 Service Pack 1 (Full Package) and install it
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Thursday, February 11, 2010 8:32 AM typo
    • Marked as answer by YiChun Chen Monday, February 15, 2010 4:28 AM
    Wednesday, February 10, 2010 9:17 AM
  • I removed .NET Framework 3.5 Service SP1, and I am running Windows 7. First I thought I did not have .NET Framework 3.5 Service SP1, and then I had set up error to install .NET Framework 3.5 Service SP1, so I uninstall it. Now what should I to put it back? It seems it did not let me install .NET Framework 3.5 Service SP1 separately and manually.

    Tuesday, March 9, 2010 4:53 PM