none
Office Add-In does not appear in COM Add-Ins list - 2003 RRS feed

  • Question

  • Hi

    I am having a strange issue on a user machine which has Office 2003 SP3.  I registered an Outlook/excel/Word Add-In using regsitry settings as follows -

    [HKEY_CURRENT_USER\Software\Microsoft\OFFICE\Outlook\Addins\MyOUTLOOKAddIn]
    "CommandLineSafe"=dword:00000001
    "Description"="MyOUTLOOKAddIn -- an addin created with VSTO technology"
    "FriendlyName"="MyOUTLOOKAddIn"
    "LoadBehavior"=dword:00000003
    "Manifest"="C:\\MyOUTLOOKAddIn.dll.manifest"
    "ManifestLocation"="C:\\"

     I set up all required CASPOL settings. This works fine on many computers except 2 of them. The machines have Office 2003 Sp3 with VSTO SE. The add-in MyOutlookAddIn does NOT show up in COM Add-Ins list. Any help is appreciated. I am struggling with this from last 2 days...

    thanks

    Friday, May 11, 2012 1:36 AM

All replies

  • could you try using process monitor to see if on those machines your registry entries are actually read?
    Friday, May 11, 2012 6:57 AM
  • I am not admin to the machine and cannot install any software on the machine..does ProcMon need admin rights?
    Friday, May 11, 2012 11:58 AM
  • installation is not necessary, simple xcopy will suffice - as for admin rights - i do not remember you have to try it yourself.
    Friday, May 11, 2012 1:04 PM
  • Hi Budding,

    Your registry entry doesn't like a Office 2003's add-in. It more likes a Office 2007/2010 add-in. As far as I know that Office 2003's add-in project will include a setup project. And it's registry entry more like a shared add-in.

    I hope these information can help you trouble shooting your issue.

    Best Regards,

    T.X.

    Monday, May 14, 2012 2:27 AM