locked
Can't login to MS Service Trust Portal with any MS account - AADSTS50020 RRS feed

  • Question

  • I need to get a copy of MS Azure's SOC2 certification so I need to login to the MS Service Trust Portal (http://aka.ms/STP). It doesn't matter which account I use - I've tried the global admin for my Azure account, an external user tied to the account, and a regular Live.com account - it will not let me login and keeps generating the following error each time. 

    How can I finally login? I've tried adding "domain_hint=" with my Azure domain but it did not help at all. (Keep in mind the error below is the same thing no matter which user I test with. Even the identity provider "live.com" never changes.)




    • Edited by noamo48 Friday, January 27, 2017 12:21 AM
    Friday, January 27, 2017 12:19 AM

All replies

  • Hello,

    Is it possible to remove and re-add the account?

    Can you refer to the solution posted in the stack overflow thread?

    Try these steps:
    Go to the directory in question. Select the Users tab and click on add users. Select "User with an existing Microsoft account" give the user Id "'n*****l@xxxx.com' & check.

    Using a tenant name doesn't work, try using a tenant id.

    For more information on this error code; Refer here

    Regards,
    Sumanth BM

    ----------------------------------------------------------------------------------------------
    Kindly click "Mark as Answer" on the post that helps you, this can be beneficial to other community members reading the thread. And Vote as Helpful.

    Friday, January 27, 2017 6:55 PM
  • I am not developing my own application or anything. I'm just trying to login to a Microsoft site. I have already tried adding a user as a global admin and using it. I tried deleting and re-adding a user. Nothing worked.

    What do you mean by using a tenant id instead? How do I get the tenant id and how do I use it?

    Friday, January 27, 2017 9:32 PM