none
How to get .Net Framework 3.0 SP2 without installing 3.5 RRS feed

  • Question

  • Hi,

    I have a application built with VS2008, SP1, targeting .Net framework 3.0

    I now find that when it comes to redistribution, I specifically need .Net Framework 3.0 SP2. I cannot find a redistributable of this that is separate from the full 3.5 framework. Does such a thing exist? And if not, why not!! I deliberately targeted 3.0 because I did not want the large 3.5 distributable.

    Thanks

    GrantaGuy


     
    Tuesday, January 20, 2009 1:38 PM

Answers

    • Marked as answer by YiChun Chen Tuesday, January 27, 2009 3:16 AM
    Wednesday, January 21, 2009 10:36 AM
  • Hi GrantaGuy,

    Microsoft Visual Studio 2008 Service Pack 1 installs both Visual Studio 2008 Service Pack 1 (SP1) and the .NET Framework 3.5 SP1.  These service packs offer Visual Studio and .NET Framework users improvements in responsiveness, stability and performance. So you don't need to uninstall VS2008 SP1.

    Deprecated code and features are those that have been retired and replaced by alternative functionality. These features or classes should not be used, and remain in the code base for the sole purpose of providing backward compatibility. It indicates that you build your application relying on deprecated elements of the framework. So your issue is related to .Net Framework, but not VS2008.

    Could you help me to check the target Framework of your application? (Project Properties >> Application >> Target Framework) If it is not based on .Net Framework 3.0, please select ".Net Framework 3.0". Make sure that you don't write any deprecated code, features or classes. Make your code and .Net Framework (that you provide to your client) compatible.

    If you have any concern about this issue, please feel free to let me know.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Tuesday, January 27, 2009 3:16 AM
    Friday, January 23, 2009 6:36 AM

All replies

    • Marked as answer by YiChun Chen Tuesday, January 27, 2009 3:16 AM
    Wednesday, January 21, 2009 10:36 AM
  • Hi GrantaGuy,

    There are standalone bootstrapper packages of .Net Framework 2.0 SP2 and .Net Framework 3.0 SP2.
    See: http://msdn.microsoft.com/vs2008/bb898654
    Although you could install them separately, it's not recommended because there are limitations. The only supported way to get 2.0 SP2 and 3.0 SP2 is to install 3.5 SP1. This is what end users will be doing as well. See: http://msdn.microsoft.com/library/bb822049

    If you have any concern about your issue, please feel free to let me know.

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, January 22, 2009 3:15 AM
  • Well, the problem is this. My app is distributed on CD, and comes with a large DB. We want to put the .Net Framework on that disk, rather than expect users to download it, but .Net 3.5 is a massive install... and we can't afford that space. Hence the decision to stick with 3.0.

    So I was surprised that after installing the SP1 of Visual Studio I can no longer rely on the compiler to tell me whether the code I'm using runs with the original 3.0 installation (as Naicul directed above). I have reworked the code that just 'blows up' but now the compiler spits out warning that I'm using deprecated code.

    Let's say I want to target 3.0 without SP2. My current thinking is that I need to uninstall VS 2008 SP1, in order to rely on the compiler. Is that correct?

    Thursday, January 22, 2009 11:04 AM
  • Hi GrantaGuy,

    Microsoft Visual Studio 2008 Service Pack 1 installs both Visual Studio 2008 Service Pack 1 (SP1) and the .NET Framework 3.5 SP1.  These service packs offer Visual Studio and .NET Framework users improvements in responsiveness, stability and performance. So you don't need to uninstall VS2008 SP1.

    Deprecated code and features are those that have been retired and replaced by alternative functionality. These features or classes should not be used, and remain in the code base for the sole purpose of providing backward compatibility. It indicates that you build your application relying on deprecated elements of the framework. So your issue is related to .Net Framework, but not VS2008.

    Could you help me to check the target Framework of your application? (Project Properties >> Application >> Target Framework) If it is not based on .Net Framework 3.0, please select ".Net Framework 3.0". Make sure that you don't write any deprecated code, features or classes. Make your code and .Net Framework (that you provide to your client) compatible.

    If you have any concern about this issue, please feel free to let me know.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Tuesday, January 27, 2009 3:16 AM
    Friday, January 23, 2009 6:36 AM