locked
Error Creating Control ReportViewer1 RRS feed

  • Question

  • User885618196 posted

    I recently downloaded Visual Web Developer Express 2010 and I am having difficulty with the report viewer control. I also downloaded the reportviewer 2010 redistibutable and added a reference to my site.  When I drag and drop from the toolbox in design view the controls error is: Failed to create designer "Microsoft.Reporting.WebForms.ReportViewer, Microsoft.Reportviewer.WebForms, version=10.0.0.0 culture=neutral PublicKeyToken=b03f5f7f11d50a3a.  It works when I view it in the browser and the report renders fine but I don't have access to it in design mode.  Also, when I attempt to view a rdlc file it's the xml version instead of design mode. 

    I have a trial version of Visual Studio on another computer so I created a reportviewer website and opened this site with the Visual Web Developer Express 2010.  The web.config relating to the reportviewer is below.

    Thanks in advance for your assistance.  There isn't much on the web to fix this problem.

    <system.web>
        <compilation debug="false" strict="false" explicit="true" targetFramework="4.0">
          <buildProviders>
            <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
          </buildProviders>
          <assemblies>
            <add assembly="Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
            <add assembly="Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
            <add assembly="System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          </assemblies>
        </compilation>
        
      </system.web>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
        <handlers>
          <add name="ReportViewerWebControlHandler" verb="*" path="Reserved.ReportViewerWebControl.axd" preCondition="integratedMode" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
        </handlers>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>

    Sunday, October 3, 2010 6:09 PM

All replies