none
Issues with POST Request

    Question

  • We are working to implement a POST request alongside an already working GET request. Any inputs we put in the request body to run a test come back with a "Backend service responded with a redirect. Response shown by-passed API Management proxy and came directly from the endpoint specified in the redirect response.". 

    Response comes back with code to our webpage (the redirect?), not the proper shape values. We have configured the POST endpoint properly as far as we know, we are just having issues with getting the Request Body input to actually respond with the proper response. 

    Are there any guides we can follow on how to execute a POST type operation and receive the proper response?


    Wednesday, December 5, 2018 10:24 PM

All replies

  • Hi JinAgggg

    Were you following any documentation? Could you provide more details around your existing implementation?

    Thursday, December 6, 2018 3:30 AM
    Moderator
  • Thanks for your reply. We follow the Azure API Management Documentation. 

    We create a POST operation by using Azure API Management. Our input parameters includes an egg shape polygon which has more than 30 endpoints. So instead passing parameters through Query, we set the request body by using JSON Format for all our parameters. When we testing the POST operation, response comes back with code to our webpage. Can you guide us how to pass body as Form Data?

    Thanks again!

    Thursday, December 6, 2018 6:23 PM