locked
The resource cannot be found error RRS feed

  • Question

  • Hi,

    I am trying to make an application in WCF. When I try to 'Deploy WCF Service to IIS', it is giving me an error. When I just type 'localhost', it is showing the default page. My OS is windows 7 professionla and it had IIS 6. I Installed IIS 7. When I type full path 'http://localhost/ProductsService/Service.svc', it is giving this error.

    Could you please help me out in solving this problem?

     

    Thanks

    Jo

    Sunday, November 13, 2011 11:10 PM

Answers

  • Hi,

    I am using IIS with .NET 4.  There was an error in app.config file while I wrote the endpoint. Fortunately the problem is resolved.

     

    Thanks very much

    Jose

    • Marked as answer by s251984 Wednesday, November 16, 2011 8:05 PM
    Wednesday, November 16, 2011 8:05 PM

All replies

  • Hello, first of all, can you make sure the service address is correct? Windows 7 does not come with IIS 6. I think you have some misunderstanding here. Anyway, have you also enabled the Windows feature named WCF HTTP Activation? This is also required for WCF services to work in IIS using the HTTP protocol.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Windows Azure Technical Forum Support Team Blog
    Tuesday, November 15, 2011 1:50 AM
  • Hi,

     

    Based on the error message it looks like you are using IIS with .NET 4.

    But can you make sure that ProductsService Virtual Directory in IIS is create as Application and it has Service.svc in it ?

     


    Thank You, Sudhakar
    Tuesday, November 15, 2011 7:27 AM
  • Hi,

    I am using IIS with .NET 4.  There was an error in app.config file while I wrote the endpoint. Fortunately the problem is resolved.

     

    Thanks very much

    Jose

    • Marked as answer by s251984 Wednesday, November 16, 2011 8:05 PM
    Wednesday, November 16, 2011 8:05 PM