WES7 EWF fails on USB drive


  • I am trying to enable EWF on a USB/UFD.  Here's what I've done:

    1. Built IBW in ICE "create IBW Image from Answer File..."

    2. Copied to USB flash drive and booted and built WES7 image onto another UFD (NTFS partion of 5GB of 8GB drive).

    3. Image builds (surprising slowly) and boots fine.

    4.  But, EWFMGR fails:  "Fails opening the target device \\?\storage#volume#{c....

    What am I missing?



    Monday, January 21, 2013 7:48 PM

All replies

  • What overlay did you select - RAM or RAM-REG? If RAM, try using RAM-REG. RAM overlay requires a empty space to create a small second partition.

    I would recommend using FBWF or EWF.

    -Sean / / Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Tuesday, January 22, 2013 1:01 AM
  • Sean,

    I used "EWF with HORM" component (Just EWF is not available in WES7 SP1).  I selected RAM-REG.  I have 3GB of free space on the UDF. 

    The registry device list has the C:\ drive and the \\?\storage#volume#{c.... which the EWF fails to open.

    BTW, I'm using "Pro Guide to WES 7" as my guide.


    Tuesday, January 22, 2013 3:07 AM
  • You are using "Bootable Windows USB Stack" with your EWF?


    Tuesday, January 22, 2013 3:43 AM
  • point 3 is about expanding the cabs. you can control this by /temp commandline to another (temp) drive for setup.exe or use offline deployment.

    Windows Embedded Developer and Scripting Guy //Germany (Preparing a blog about Windows Embedded Standard)

    Tuesday, January 22, 2013 8:13 AM
  • Yes, I have included "Bootable Widnows USB Stack".  The final image boots fine.  Just ewfmgr fails for all commands.  I even tried ewfcfg but got the same error.
    Tuesday, January 22, 2013 2:07 PM
  • Will it run the setup faster with such changes?
    Tuesday, January 22, 2013 2:08 PM
  • From what I'm reading, I need to make the USB drive non-removable.  Is this true?
    Tuesday, January 22, 2013 4:53 PM
  • Not really, once you have the bootable USB stack package in the image, it should see the driver. The USB flash drive needs to be formatted with NTFS and marked as bootable - you can use diskpart to perform the setup.

    Try FBWF and see what happens.

    -Sean / / Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Tuesday, January 22, 2013 5:22 PM
  • Well, that was a waste of time.  Apparently, the WES7 image I built is a little more robust that XPE.  I needed to open the cmd windows via "run as administrator".

    Tuesday, January 22, 2013 6:09 PM
  • Oh, bitten by UAC.

    While I have that in my image, I have it turned off.

    Product > Operating System > Foundation Core > Windows Embedded Edition


    Make "Enable LUA" False

    Suddenly a lot of your troubles go away. (ignore the warning when you verify)


    Tuesday, January 29, 2013 2:55 AM
  • Please check if the below link helps

    Wednesday, February 27, 2013 9:37 AM