locked
Error - Access denied after Restore RRS feed

  • Question

  • WSS 3.0, Server 2003

    I've been developing a SharePoint site on a Virtual 2003 server on my workstation.  Today was the day to install it on the client's server, so I did the backup, copied the file across to their server, and did the restore.  From memory the command line I used was

    stsadm.exe -o restore -url http://myserver -filename "C:\Shared\mybackup.bak" -overwrite

     The tool reported that the operation was successful, but when I tried to go to the site it showed the Error - Access denied page.  It offered me to log on as a different user, but as I was already logged on as the server administrator ....I've tried an IISRESET. 

    Have I missed something?  The site is set up to use Windows Authentication.

    Thanks

    Edward
    Tuesday, November 10, 2009 6:35 PM

Answers

All replies

  • Hop into Central Admin > Application Management > Site Collection Administrators and make sure your client's domain admins are setup properly.

    HTH
    David Lozzi
    Delphi Technology Solutions
    SharePoint & Dev Blog  |  LinkedIn | Twitter
    • Marked as answer by Edward444 Wednesday, November 11, 2009 12:13 PM
    Tuesday, November 10, 2009 6:59 PM
  • you have probably made backup for sie, so all security settings now inheriuted from new site collection. you need to set up site collection administrator first. you can do it in Central Administration.
    Tuesday, November 10, 2009 7:00 PM
  • Hi,

    Please check your event log and tell us what in it regarding this issue
    Best Regards, Ammar MCT
    Tuesday, November 10, 2009 7:03 PM
  • Thanks Guys.  I'm not in the office right now but when I get back I'll check. These sound like promising leads....

    Edward
    Tuesday, November 10, 2009 7:08 PM