none
"Error querying data source" connecting to User Profile Web Service with InfoPath 2013 (AD + SQL + SharePoint 2013 VMs on Azure) RRS feed

  • Question

  • Hey everyone,

    I used this excellent guide by Keith Mayer to setup a SharePoint 2013 environment in a Windows Azure trial.

    There's an AD VM, a SQL Server 2012 VM and a SharePoint 2013 VM.

    I setup SharePoint 2013 without issues and everything was working fine, until I decided that I needed to get the logged in users information into a text box in one of the lists.

    Until then, I had been using InfoPath 2013 (List settings -> Form settings -> customize current form using InfoPath) to make modifications to the form and everything was working fine.

    Following posts on the Internet, I learned that to add logged in user information, I needed to add a connection to http://sharepointsite/_vti_bin/UserProfileService.asmx and I did this without issues. However, as soon as I did this and published the form, I started getting this error every time I opened the form for editing.

    I have tried method 2 found here: http://www.jeremytaylor.net/2010/05/24/sharepoint-disable-loopback-check-disableloopbackcheck-dword-in-registry/

    I have also tried "Use the Secure Store Service in SharePoint Server 2010 to store alternate credentials for the data connection." found here: http://support.microsoft.com/kb/981684

    I don't know why I'm getting this error and how to fix it. I'm not sure if it's because everything is running on Azure.

    I've been looking into this since yesterday and I'm running out of things to try. I think it's a permission issue, but I'm not sure how to troubleshoot it.

    If anyone can help me, I'd appreciate that!

    Thank you!

    Sri

    Thursday, July 25, 2013 1:23 AM