locked
No Speed Update for Generic Differential Drive RRS feed

  • Question

  • Hello,

    I hope this topic has not been discussed yet. I've been searching for it without any success, so now I'll post my problem :)

    When starting the Visual Simulation Environment "Pioneer 3DX Simulation" (or any other Sim using the pioneer) and I start driving around, I should be able to see the current speed (leftwheel / rightwheel) in the httpget-file (e.g. http://localhost:50000/simulateddifferentialdrive/45c8c460-9b21-4301-a6eb-6f1141b732f3/drive ). However the speed won't update and remains 0 all the time (<LeftWheel><WheelSpeed>0</WheelSpeed>...) even though other things like the "enabled" tag switches on turning the robot off or on. Even the laser-range-finder changes its values when moving around and the contact sensor works as well.

    Edit: btw I tried both, simulated drive and "usual" drive...both act the same way: update on "enabled" and the timestamp, but nothing else...

    Oh and: I also tried "Get" on these values (leftwheel speed and so on) from another service, which subscribed to the drive and I could read initial values like wheel distance and so on, but the speed (or power) didn't change even after I set it using my service. Setting works but reading (getting) not => bug, intended or just a little weird?

    Does anyone know why? I have tried some things already, but I just don't have no idea why the speed doesn't update (the power neither btw). Any suggestions would be helpful!

    Thanks a lot and merry christmas :)
    Kay
    Monday, December 22, 2008 9:00 AM

Answers

  • I have had a look at the code and this appears to be a problem in the Simulator. The Simulated Differential Drive looks like it sets a value for state.LeftWheel.MotorState.CurrentPower, but it seems that the entity's MotorTorque is always zero. I will have to get somebody else to look at it.

    Please post future questions about the simulator in the Simulation forum.

    Trevor
    Saturday, December 27, 2008 3:37 AM