none
Troubleshooting HLK Setup RRS feed

  • Question

  • I am currently trying to install the Windows HLK on a test server running Windows Server 2008 R2 64-bit with SP1 which is not a domain controller. I am receiving the error message "The Controller option is not supported on this platform. The Controller option may only be used on systems running the English language versions of Windows Server 2012, 2012 R2, and 10 that are not configured as domain controllers", even though two of Microsoft's troubleshooting documents say that the Controller option is supported on Windows Server 2008 R2 64-bit with SP1:

    “English language and English local version of Windows Server 2008 R2 64-bit with service pack (SP1), Windows Server 2012, or Windows Server 2012 R2. For information, see the Windows Server website.”

    If you encounter issues installing the Windows HLK Controller, confirm the following:

    • The operating system uses the English language (en-us) version of Windows Server 2008 R2 x64 or Windows Server® 2012 and is not running as a domain controller.”

    Does anyone know why this is happening?



    Friday, June 23, 2017 12:13 PM

All replies

  • Hi RICHARDSONW,

    Which HLK version you download??

    Monday, June 26, 2017 8:41 AM
  • Version 1703
    Monday, June 26, 2017 12:13 PM
  • Looking at the following URL,
    Https://msdn.microsoft.com/en-us/library/windows/hardware/dn915004(v=vs.85).aspx

    =============
    Important

    Controller setup will fail if .NET Framework 4.5 has not previously been installed installed.

         Http://www.microsoft.com/en-us/download/details.aspx?id=30653

    32-bit SQL Server installations are not supported. You must uninstall any 32-bit SQL Server installation prior to installing the HLK.

    SQL Server 2014 is not supported. You must uninstall any SQL Server 2014 installations prior to installing the HLK.
    =============

    Is the .NET Framework 4.5 installed?
    Monday, June 26, 2017 11:56 PM
  • Hi RICHARDSONW,

    Maybe you can check your installation log.

    Please see the following website to check

    https://msdn.microsoft.com/en-us/library/windows/hardware/dn393918(v=vs.85).aspx

    Tuesday, June 27, 2017 1:52 AM
  • Looking at the following URL,
    Https://msdn.microsoft.com/en-us/library/windows/hardware/dn915004(v=vs.85).aspx

    =============
    Important

    Controller setup will fail if .NET Framework 4.5 has not previously been installed installed.

         Http://www.microsoft.com/en-us/download/details.aspx?id=30653

    32-bit SQL Server installations are not supported. You must uninstall any 32-bit SQL Server installation prior to installing the HLK.

    SQL Server 2014 is not supported. You must uninstall any SQL Server 2014 installations prior to installing the HLK.
    =============

    Is the .NET Framework 4.5 installed?

    Yes, .NET Framework 4.5 was installed, and 32-bit SQL Server was uninstalled.
    Tuesday, June 27, 2017 12:14 PM