locked
aspnetdb.mdf not created!!!! RRS feed

  • Question

  • User452046018 posted
    i have a problem with this club starter kit! in the "introduction to the Club Web Site Starter Kit" it is said that th aspnetdb.mdf is automatically created when you open the web administration tool and click the securitiy tab. Well, my problem is that it is not created, and says "unable to connect to database". Does anyone know what the problem is!?
    Friday, August 5, 2005 8:09 AM

All replies

  • User-626128219 posted
    Hi I get the same error. I just dowloaded and installed the Club kit, this just to learn asp and have something to work with.
    I have not find any step by step instruction to install it so I'm doing on a touch.

    When trying to access the security page I get an erorr saying unable to connect to the SQL server database.
    I'm not sure how to overcome this, have I forgetten something in the setup, perhaps I have to setup a link to the DB in Visual Web Developer tool to the datase, or ?

    All help would setting this up would be most appreciated ..

    Best Regards
    Lars Karlsson

    PS I have sql server 2000 installed.
    Sunday, August 14, 2005 4:51 PM
  • User1275835593 posted
    The file generated automatically for me. My only guess is to make sure the SQLExpress instance of 2005 is up and running.
    Wednesday, August 17, 2005 10:18 PM
  • User904555280 posted
    Yeah, you might have to first download SQL Express Beta 2 from http://lab.msdn.microsoft.com/express/sql/.
    Additionally, if you see that the database file exists, check the NTFS permissions on it.  It should inherit permissions from the App_Data folder, which should include Read and Write permissions for the ASPNET account.
    Thursday, September 1, 2005 5:57 PM
  • User-244778138 posted

    How are you trying to run the site?  As someone noted below, check the NTFS permissions on the app_data folder.  That bit me once or twice.  Also, I've had better luck launching my sites from within the IDE by pressing <CTRL> and <F5> - I'm not quite sure why yet, but it works better.  I'm rather green at this also so far.

    Allen

    Thursday, September 22, 2005 10:03 AM