locked
SQL SERVER REPORTING SERVICES ERROR WHILE CONNECTING TO SAP HANA RRS feed

  • Question

  • DEAR DUDES I AM FACING THE BELOW PASTED ERROR WHILE TRYING TO CONNECT TO SAP HANA 

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection)
        • ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

        ERROR INSIGHTS:I AM USING WINDOWS AUTHENTICATION TO LOG IN TO MY SSRS SERVER.

        SAP HANA IS USED BY CONNECTING THROUGH ODBC CONNECTIVITY I AM ABLE TO GET SUCCES REMINDER IN VISUAL STUDIO  2017 ,ABLE TO BUILD,DEPLOY BUT AAFTER CLICKING RUN IN VS 2017 IT ASKS ME FOR A UID PWD WHICH I AM ENTERING AS SQL SERVER CREDENTIALS BUT REPORT WILL NOT RUN.

        NOTE:1.THE UID /PWD USED FOR SAP HANA ODBC IS DIFFERENT COMPARED TO MSBI UID/PWD .I AM SUSPECTING DO WE NEED TO HAVE THE SAME UID/PWD AS MSBI FOR SAP ODBC AS WELL .I THINK IT NEED NOT BE OR SHOULD I USE ODBC UID/PWD  AND CREATE A SERVICE ACCOUNT SO BOTH WILL MATCH AND RUN.

        2.SQL SERVER AS DATA SORC RUNS FINE AND REPORTS ARE ALSO RUNNING PROPERLY

        THANKS IN ADVANCE

    Thursday, March 14, 2019 9:47 AM

All replies

  • DEAR DUDES I AM FACING THE BELOW PASTED ERROR WHILE TRYING TO CONNECT TO SAP HANA 

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection)
        • ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

        ERROR INSIGHTS:I AM USING WINDOWS AUTHENTICATION TO LOG IN TO MY SSRS SERVER.

        SAP HANA IS USED BY CONNECTING THROUGH ODBC CONNECTIVITY I AM ABLE TO GET SUCCES REMINDER IN VISUAL STUDIO  2017 ,ABLE TO BUILD,DEPLOY BUT AAFTER CLICKING RUN IN VS 2017 IT ASKS ME FOR A UID PWD WHICH I AM ENTERING AS SQL SERVER CREDENTIALS BUT REPORT WILL NOT RUN.

        NOTE:1.THE UID /PWD USED FOR SAP HANA ODBC IS DIFFERENT COMPARED TO MSBI UID/PWD .I AM SUSPECTING DO WE NEED TO HAVE THE SAME UID/PWD AS MSBI FOR SAP ODBC AS WELL .I THINK IT NEED NOT BE OR SHOULD I USE ODBC UID/PWD  AND CREATE A SERVICE ACCOUNT SO BOTH WILL MATCH AND RUN.

        2.SQL SERVER AS DATA SORC RUNS FINE AND REPORTS ARE ALSO RUNNING PROPERLY

        THANKS IN ADVANCE

    You need to set username and password for data source in the data source settings and should not use integrated security option. The username pwd should correspond to the one you use to connect to SAP HANA

    This you would need to set up from report server


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page


    • Edited by Visakh16MVP Thursday, March 14, 2019 11:31 AM
    Thursday, March 14, 2019 11:27 AM
  • NO NEED TO YELL

    You use a ODBC DSN name for the connection and by the error message that one don't exists on the server where SSRS is running.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Thursday, March 14, 2019 12:50 PM
  • i tried this a week ago system/user dsns both did not work.

    shared data source also doesn't work.

    i am using the sap hana for cognos/bos they are running fine fron 3 years.

    Friday, March 15, 2019 3:31 AM
  • How do I resolve error, "(IM002) [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"   

    this also not workinggggggggggggggg

    Saturday, March 16, 2019 4:58 PM
  • How do I resolve error, "(IM002) [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"  not workinggggggggggggggggggggggggggggg
    Saturday, March 16, 2019 4:59 PM
  • HE LLO ANY ONE HAVE THE EXPERIENCE IN INTEGRATIONG SQL SERVER REPORT SERVERS WITH SAP HANA.

    FACING THE BELOW ERROR SCREWING UP.

    How do I resolve error, "(IM002) [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"

    tried systm dsn BELOW IS ERROR

    • error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'DEV1'. (rsErrorOpeningConnection)
        • ERROR [IM014] [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application


    Saturday, March 16, 2019 5:03 PM
  • Have you create DSN already? Did you create user DSN or system DSN? Also did you create 32 bit or 64 bit DSN?

    Is the above error happening in SSDT/VS shell or when report is run from report server?


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Saturday, March 16, 2019 5:54 PM
  • How do I resolve error, "(IM002) [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"  not workinggggggggggggggggggggggggggggg

    Answer in the other thread you opened

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/b7990716-fb50-4288-a5ac-6a228e271776/ssrs-report-server-integration-with-sap-hana-odbc-sources?forum=sqlreportingservices


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Saturday, March 16, 2019 6:00 PM